WordPress.org

Support

Support » How-To and Troubleshooting » Escape characters suddenly appear

Escape characters suddenly appear

  • WHile reediting a file I noticed backslashes starting to appear. Not only in words like it\’s but also in my links rendering them useless.

    Even when I deleted the backslashes, and saved them, what happened was the slashes not only reappeared, but were doubled, such as it\\’s.

    I am staying away from re-editing my posts now, because I want to see why this is happening — so as not to ruin the posts which are working okay.

    This didn’t happen before, I could reedit a post — via the manage posts panel with no problem.

    Any links regarding this issue?

    Thanks

    Rowby

Viewing 2 replies - 1 through 2 (of 2 total)
  • Mmh. This is a problem with characters not being properly unescaped. I faced it recently while setting up OSCommerce with TinyMCE, but never with WordPress. What WP version are you using?

    Typically, you’d look at a missing stripslashes() call in the script method building up the faulty textarea data.

    Hi I’m using the most recent version 1.5.1.3
    >> Typically, you’d look at a missing stripslashes() call in the script method building up the faulty textarea data.
    Is there a specific file I should search through for the ” missing stripslashes() call “? More specifically what do I look for and what would I replace it with — if you know.

    Thanks

    Rowby

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Escape characters suddenly appear’ is closed to new replies.
Skip to toolbar