Support » Plugin: Codestyling Localization » es_ES.po file empty

  • Resolved mrubio

    (@mrubio)


    Hi,
    I’ve translated a theme into Spanish with your plugin, but I have realised it is not enough: there are certain messages that I assume belong to WordPress and need to be translated there.
    So I tried to do so: If I understood well, your plugin generates a .po file in wp-content/languages. It seems to be empty. At least I assume that’s whats happening, because I can’t seem to translate it, neither inside the plugin, nor downloading the es_ES.po file and opening it with Poedit (it appears empty).

    I am not a programmer. I’m doing my best 😛 Excuse me if I say something stupid 🙂

    http://wordpress.org/extend/plugins/codestyling-localization/

Viewing 1 replies (of 1 total)
  • Plugin Author codestyling

    (@codestyling)

    There a several point to meet to get WordPress showing the es_ES translations:
    1.) your wp-config.php should have WPLANG set to “es_ES”
    2.) your folder /wp-content/languages/ should have the appropriated WordPress Core translation files for es_ES (WordPress itself)
    3.) your Theme should have the correct es_ES translation files at the themes folder defined by author of theme (should be handled by my plugin)
    4.) you need the *.mo files to get translations show, don’t forget to generate the mo-file for the theme.

    If you meet this conditions, you should get the spaninsh translations. The only things you won’t get, are:
    – if Theme author did accidentally use the textdomain “default” within the theme, you will not get this translations as long as they are not contained at the WordPress core translations.
    – if Theme author used copied code with different textdomains for other Themes/Plugins you won’t get the translations
    This 2 points can only be changed by editing the Theme and set the correct Themes textdomain. This have to be done preferably by the Theme author. My Plugins warns about more than one textdomain within a Theme or Plugin. If you get this warning during translation, it have to be solved by Theme author.

Viewing 1 replies (of 1 total)
  • The topic ‘es_ES.po file empty’ is closed to new replies.