Viewing 15 replies - 1 through 15 (of 43 total)
  • Plugin Author hupe13

    (@hupe13)

    filename ist eine Option, ob der Name des Startpunktes (elevation-track) bzw. die Namen der Tracks (multielevation) aus dem Dateinamen generiert werden soll oder nicht. Wenn nicht, wird versucht, den Namen aus den Daten in der Datei zu bestimmen. 0/1 soll entweder/oder bedeuten. Also entweder weglassen oder filename=0 oder filename=1 angeben.

    Manche benennen ihre Dateien entsprechend, manche die Tracks in der Datei.

    • This reply was modified 11 months, 1 week ago by hupe13.
    Thread Starter Andreas

    (@andreas2021)

    Ich habe das plugin neu installiert und den jetzt den shortcode reduziert auf :

    [elevation gpx=”https://www.steinszeit.de/wp-content/uploads/gpx/20230811-Alpinsteig-Pockau.gpx”%5D
    [elevation gpx=”https://www.steinszeit.de/wp-content/uploads/gpx/20230813-Anton-Guenter-Stein-Bruchberg-Stoesserfelsen.gpx”%5D
    [multielevation]

    Anzeige im Frontend: Keinerlei Karten- oder Trackanzeige, nur der Ausdruck:

    Bewege die Maus über einen Track oder wähle einen im Control Panel aus …

    Was mir noch aufgefallen ist:

    Wenn ich im Reiter “Dateien für Leaflet Map” unter Anzeige der Dateien” die Dateien anzeigen lasse, und bei einem beliebigen Track auf Vorschau klicke, kommt immer der gleiche Kartenausschnitt aus Halifax. Hochgeladen am, Dateiname, Filegröße und Trackname stehen korrekt drin, Zeit fehlt.

    Die Vorschau passt also schon nicht.

    PS: Warum hier im Form oben das %5D angehängt wird, weiß ich nicht.

    • This reply was modified 11 months, 1 week ago by Andreas.
    • This reply was modified 11 months, 1 week ago by Andreas.
    • This reply was modified 11 months, 1 week ago by Andreas.
    Plugin Author hupe13

    (@hupe13)

    Anzeige im Frontend: Keinerlei Karten- oder Trackanzeige,

    [leaflet-map fitbounds] steht als erster Befehl?

    bei einem beliebigen Track auf Vorschau klicke, kommt immer der gleiche Kartenausschnitt

    Das kann ich mir ohne weitere Informationen nicht erklären. Ich habe es gerade auf meiner Testseite überprüft und auch im Code steht überall fitbounds. Bringt die Entwicklerkonsole irgendwelche Fehler? Siehst du dort im Reiter “Netzwerkanalyse” dass alle Dateien geladen werden?

    P.S. Ich glaube ich habs: Siehe https://de.wordpress.org/plugins/extensions-leaflet-map/#my%20gpx%20file%20is%20not%20displayed%21

    Trage in die .htaccess ein:

    AddType application/gpx+xml gpx
    RewriteRule .*.gpx$ – [L,T=application/gpx+xml]

    • This reply was modified 11 months, 1 week ago by hupe13.
    Thread Starter Andreas

    (@andreas2021)

    Ich habe das in die .htaccess eingetragen, muss ich das nochmal irgendwie aktivieren?

    Jetzt kommt x-mal der Ausdruck

    [elevation-track read error lat= lng= name= ]

    Habe das mal rückgängig gemacht!

    • This reply was modified 11 months, 1 week ago by Andreas.
    • This reply was modified 11 months, 1 week ago by Andreas.
    • This reply was modified 11 months, 1 week ago by Andreas.
    Plugin Author hupe13

    (@hupe13)

    Eigentlich nicht, Hauptsache, es steht vor # BEGIN WordPress.

    Thread Starter Andreas

    (@andreas2021)

    Es tut sich was! Ich hatte die htaccess zurückgeändert. Seitdem wird es angezeigt. Da stand also irgendwas drin, was gestört hat.

    https://www.steinszeit.de/deutschland/erzgebirge/wandern-bei-olbernhau/

    Sieht alles noch etwas verbesserungswürdig aus, aber die Tracks werden angezeigt.

    Die .htaccess hatte ich mit einem Plugin wp-htaccess-editor geändert (habe damit wenig Erfahrung!!) , dann mit dem dortigen “Restore Last Backup” zurückgesetzt.

    Plugin Author hupe13

    (@hupe13)

    Die .htaccess hatte ich mit einem Plugin wp-htaccess-editor geändert

    Das kenne ich nicht. Aber ohne die o.g. Zeilen wird dir die Vorschau im Backend weiterhin nicht angezeigt. Dort wird leaflet-gpx verwendet, das braucht diese Einstellung.

    Aber irgendwas stimmt prinzipiell noch nicht. Ich sehe einen Fehler in der Entwicklerkonsole, welches evtl. auf einen Konflikt mit einem anderen Plugin hindeutet. Mach am besten mal eine Testseite nur mit der Karte.

    • This reply was modified 11 months, 1 week ago by hupe13.
    Thread Starter Andreas

    (@andreas2021)

    Ich habe die Zeilen wieder eingefügt, und eine Testseite angelegt.

    Die Vorschau passt aber trotzdem noch nicht.

    https://www.steinszeit.de/test/

    Nun zeigt es auf allen Seiten keine Tracks mehr an, es scheint nun also auch da das Vorschau-Problem zu bestehen.

    • This reply was modified 11 months, 1 week ago by Andreas.
    Plugin Author hupe13

    (@hupe13)

    Au weia, deine gpx-Dateien sind weg!

    Thread Starter Andreas

    (@andreas2021)

    Weg sind die nicht, sie liegen noch im upload-Verzeichnis. Aber die WP-GPX-Maps kollidiert mit leaflet und das funktioniert (noch) nicht richtig. Problem bleibt, dass kein Track angezeigt wird.

    Plugin Author hupe13

    (@hupe13)

    Wenn die Tracks noch im upload-Verzeichnis liegen, dann ist irgendwas an der .htaccess noch falsch. Ich bekomme, wenn ich eine gpx-Datei abrufe (mit wget), ein “nicht gefunden” als Antwort.

    Thread Starter Andreas

    (@andreas2021)

    Meine htaccess sieht so aus.

    #Begin Really Simple Security
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTPS} !=on [NC]
    RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]
    AddType application/gpx+xml gpx
    RewriteRule .*.gpx$ – [L,T=application/gpx+xml]
    </IfModule>
    
    Options -Indexes
    #End Really Simple Security
    # BEGIN WordPress
    # Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Ich mußte nun erstmal alles stoppen, damit die Tracks wieder angezeigt werden.

    Ich hatte noch überlegt, ob es an einer fehlerhaften Transformation der Files zu leaflet liegt. Ich hatte es bei sgpx belassen.

    Wie kann ich die GPS-Tracks übrigens ohne WP-GPX-Maps hochladen?

    Plugin Author hupe13

    (@hupe13)

    Die .htaccess sieht eigentlich richtig aus. Im deutschen Forum wird gesagt, dass man Really Simple Security nicht wirklich benötigt, wenn alles richtig auf https umgestellt wurde.

    Ansonsten frag mal deinen Hoster, ob man die o.g. Anweisung eintragen darf und wenn ja, wo.

    Wie kann ich die GPS-Tracks übrigens ohne WP-GPX-Maps hochladen?

    siehe https://deine-domain.tld/wp-admin/admin.php?page=extensions-leaflet-map&tab=filemgr

    Thread Starter Andreas

    (@andreas2021)

    Ich habe noch etwas getestet, leider ohne Erfolg. Was mich stutzig macht, dass bereits auf der pluginseite https://www.meinewebsite/wp-admin/admin.php?page=extensions-leaflet-map&tab=filemgr-list die Vorschau der in /gpx/ gespeicherten Tracks nicht funktioniert. Die Tracks werden angezeigt, aber die Vorschau klappt nicht. Solange ich dort nicht weiterkomme, brauche ich nichts weiter zu versuchen. Diese Anzeige muss erst einmal passen.

    Plugin Author hupe13

    (@hupe13)

    Teste mal:

    [leaflet-map fitbounds]
    [leaflet-gpx src=https://url/to/file.gpx]Test[/leaflet-gpx]

    Falls das nicht angezeigt wird und kein 404-Fehler in der Entwicklerkonsole kommt, liegt es an dem Eintrag in der .htaccess:

    AddType application/gpx+xml gpx
    RewriteRule .*\.gpx$ - [L,T=application/gpx+xml]

    Frag bitte deinen Hoster, wo sowas eingetragen werden muss. Ich muss es bei Strato in das .htaccess in der Wurzel des “Home”verzeichnisses eintragen und nicht in das .htaccess im Verzeichnis, in dem die WordPress-Installation ist.

    • This reply was modified 11 months ago by hupe13.
    • This reply was modified 11 months ago by hupe13. Reason: Falschen Ausschnitt aus .htaccess kopiert
Viewing 15 replies - 1 through 15 (of 43 total)
  • The topic ‘Erste Multitrackkarte’ is closed to new replies.