Errors with adding categories and writing posts (5 posts)

  1. DavidSWP
    Posted 9 years ago #

    My site has just developed a serious problem after I tried to add a category on the 'Write Posts' Screen.

    When I tried to add a category initially it says:

    'That category name is invalid. Try something else.'

    I then try something else and it creates about 5 new entries in my categories display all called 'undefined'.

    After this has happened I couldn't access the Write Post screen or the Manage Categories screen again, I just get a blank screen and my browser says 'done' - no error messages or anything.

    I then tried restoring my database from my local computer but this only fixes the problem until I try to add a category after which I get the exact same problem.

    Any ideas? Its driving me mad and has made my site useless.

    PHP 4.3.11
    MySql 4.025
    WP version - latest

  2. Chris_K
    Posted 9 years ago #

    Out of curiosity, what OS and browser are you using?

    Does this happen if you try with a different browser?

  3. DavidSWP
    Posted 9 years ago #

    XP Professional SP 2 and Firefox latest version.

    Ok, I have the exact same files and exact same database content on my local server and on my ISP's server, but I don't have a problem on my local server setup meaning its an issue with my ISP's PHP 4.3.11 or Mysql 4 since I have PHP 5 and Mysql 5 locally.

    Any ideas how to resolve this, I have heard a few people say that WP and PHP 4.3.1 don't mix well. Is this true?

  4. DavidSWP
    Posted 9 years ago #

    So whats up with it? This is a big bug, can one of the developers please reply?

  5. redstone_
    Posted 9 years ago #

    Hey I have recently developed a similar problem and Have been unable to find a solution for it. I can no longer post, write or comment on the forum. Now the forum worked quite well till a few days ago. but now I get the following error

    WordPress database error: [Duplicate entry '0' for key 1]
    INSERT INTO wp_postmeta (post_id,meta_key,meta_value) VALUES ('0','_pingme','1')

    WordPress database error: [Duplicate entry '0' for key 1]
    INSERT INTO wp_postmeta (post_id,meta_key,meta_value) VALUES ('0','_encloseme','1')

    Warning: Cannot modify header information - headers already sent by (output started at /homepages/30/d161313289/htdocs/kartidzo/wp-includes/wp-db.php:102) in /homepages/30/d161313289/htdocs/kartidzo/wp-includes/pluggable-functions.php on line 272


    I have tried looking up the php page, in this case wp-db.php, and checked to see if there were adverse spaces (there werent) and then checked line 102 which was the db error check routine.

    did my ISP upgrade mysql or something? because it sure seems like a db error to me.

    thanks for all your help


Topic Closed

This topic has been closed to new replies.

About this Topic