WordPress.org

Support

Support » Plugins and Hacks » Stop Spammers Spam Prevention » Errors with 4.1 ver of Stop Spammers

Errors with 4.1 ver of Stop Spammers

  • Following warnings are seen after upgrading this plugin to 4.1
    Deleting and re-installing didn’t help either.

    Downgrading to 4.0 helped.

    Warning: fopen(/home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/sfs_debug_output.txt) [function.fopen]: failed to open stream: Permission denied in /home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/stop-spammer-registrations.php on line 1184

    Warning: fwrite(): supplied argument is not a valid stream resource in /home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/stop-spammer-registrations.php on line 1185

    Warning: fclose(): supplied argument is not a valid stream resource in /home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/stop-spammer-registrations.php on line 1186

    Warning: mkdir() [function.mkdir]: Permission denied in /home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/stop-spammer-registrations.php on line 1227

    Warning: fopen(/home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/sfs_debug_output.txt) [function.fopen]: failed to open stream: Permission denied in /home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/stop-spammer-registrations.php on line 1184

    Warning: fwrite(): supplied argument is not a valid stream resource in /home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/stop-spammer-registrations.php on line 1185

    Warning: fclose(): supplied argument is not a valid stream resource in /home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/stop-spammer-registrations.php on line 1186

    Warning: mkdir() [function.mkdir]: Permission denied in /home/site/public_html/wp-content/plugins/stop-spammer-registrations-plugin/stop-spammer-registrations.php on line 1227

    http://wordpress.org/extend/plugins/stop-spammer-registrations-plugin/

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have this installed on one multisite and two standalone wordpress installations (now 3.5), and have not had this issue.

    Where do you see this?

    Plugin Author kpgraham

    @kpgraham

    It is a permissions issue. You do not have rights to write to the directory.

    The workaround is to go into the options page and set the size of the log file to 0. This will prevent the file from being written.

    I will look for a way to check to see if the file is writeable and include it in a new beta version tonight or tomorrow morning.

    Keith

    Thanks Keith. But the cache and the history depth which is set to 25 (which I believe is the default) works with 4.0
    Why is there a permissions issue on upgrading to 4.1?

    Plugin Author kpgraham

    @kpgraham

    The plugin writes a history file to the content directory.

    I am making it so there will be an option with a default of OFF in the next release.

    Keith

    Plugin Author kpgraham

    @kpgraham

    Version 4.2 beta now stops these errors and by default turns off the error logging.

    It turns out that many people do not have permissions set to write to the wp-content folder.

    Please go to:

    http://www.blogseye.com/beta-test-plugins/

    and download the latest version if you have having trouble.

    The other alternative might be to give 666 permissions to the wp-content directory.

    Keith

    Well, wp-content does have user write permissions. The group & world have read+execute.

    But I get it. Thank you.

    Plugin Author kpgraham

    @kpgraham

    I am testing a version that has this feature turned off by default and I will change it so it writes to the plugin’s own directory. This will get rid of 99% of the errors.

    It will be done after Christmas, though. Things are a little hectic right now.

    Keith

    Awesome..thanks for the update. Have a wonderful one.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Errors with 4.1 ver of Stop Spammers’ is closed to new replies.
Skip to toolbar