Support » Fixing WordPress » errors when activating WP-ECOMMERCE plugin after server move

  • hi all.

    im currently pulling my hair out, just so your all aware 🙂

    I originally setup wordpress on a shared hosting environment with fasthosts – the package was on a windows box and all was working correctly, my client had been uploading tons of content whilst we worked on the site – all was going well.

    part of the project required WP ECOMMERCE to be installed to give a shop functionality, this was working… sort of. I had a few issues with it but on the whole, it didnt really break any of the WP installtion.

    I spoke to fasthosts and they advised me it should be on a linux server as that would give me better control over tmp directories etc as this is what was causing a few issues with the wp ecommerce plugin. I made the move and BAM, I had problems left right and centre – those are all fixed now, and the site is back up and running on the linux environment, no problems…. except…

    when I try to activate the wp-ecommerce plugin, it takes the ENTIRE website down, no front end, no back end. the only thing I can do is to log into phpmyadmin and deactivate the plugin (which subsequently deactivates all plugins) – and the site is back up (I have to go and then reactivate all other plugins manually)

    so im back at square one.

    I have checked in the error_log and this is what it comes up with:

    [warn] mod_fcgid: stderr: PHP Warning: require(/home/linweb02/s/ [function.require]: failed to open stream: No such file or directory in /home/linweb02/s/ on line 21

    [Sun Jul 24 13:57:37 2011] [warn] mod_fcgid: stderr: PHP Fatal error: require() [function.require]: Failed opening required ‘/home/linweb02/s/’ (include_path=’.:/usr/share/pear:/usr/share/php’) in /home/linweb02/s/ on line 21

    so – ive been searching everywhere, I have changed the permissions on files, that is not the issue, I have deleted all the wp ecommerce plugin files and re-uploaded, I have deleted all references to the plugin from the database. none of this has any effect.

    my guess it is something to do with the path of the old server, still remaining somewhere, but where, as everything refers to using the ABSPATH – and as you can see by the error code, it is looking in the right place.

    the wp-settings.php and load.php both have normal filesizes and have not been touched in any way

    I REALLY NEED HELP with this – as I dont know where else to look, and every time I try to activate, BOOM, the site goes down and I have to go through the rigmarole of deactivating and reactivating things through the DB.

    I have attempted to contact the support team at getshopped and instinct (makers of the plugin) but with no response. im sure there is something that can be done (nothing is impossible right) – I just need an expert with wordpress / php to give a lending hand.

    reinstallation on the server is not an option due to so many changes that have been made (none that have effected this from working)

    the site in questions is


Viewing 4 replies - 1 through 4 (of 4 total)
  • Update.

    just out of curiosity – I tried another plugin – jigoshop, and upon activation it crashed the backend as before, but this time, the front end still works!!

    so it is not specifically the plugins fault (my guess) – but something to do with my WP installation…

    again…. HELP!


    scratch that – jigoshop does seem to be working.
    but I have only installed this as a test – the problem still remains with WPSC

    still screaming for help, please dont ignore


    DONT scratch that.. there is something definitely up on first impressions jigoshop seemed to be ok – but trying to save any settings, do anything with the admin causes it to 500 error with the erros mentioned above.

    defo something up with WP

    help, again, someone, anyone.

    [No bumping, please.]

    Hi volcomjon

    Did you ever get a solution for this, im having exactly the same issue, and cant work out what it is?


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘errors when activating WP-ECOMMERCE plugin after server move’ is closed to new replies.