Support » Plugin: Prismatic » Errors/Warnings in PHP 7.x

  • Resolved Shaun Roselt

    (@shaunroseltgmailcom)


    I just updated to PHP 7.3.6 and I seem to be getting these Errors/Warnings:

    FILE: /home/programming/public_html/wp-content/plugins/prismatic/inc/settings-callbacks.php
    —————————————————————————————————————-
    FOUND 0 ERRORS AND 5 WARNINGS AFFECTING 5 LINES
    —————————————————————————————————————-
    151 | WARNING | Global with anything other than bare variables is discouraged since PHP 7.0. Found ${$setting}
    194 | WARNING | Global with anything other than bare variables is discouraged since PHP 7.0. Found ${$setting}
    213 | WARNING | Global with anything other than bare variables is discouraged since PHP 7.0. Found ${$setting}
    234 | WARNING | Global with anything other than bare variables is discouraged since PHP 7.0. Found ${$setting}
    253 | WARNING | Global with anything other than bare variables is discouraged since PHP 7.0. Found ${$setting}
    —————————————————————————————————————-

    FILE: /home/programming/public_html/wp-content/plugins/prismatic/inc/prismatic-core.php
    —————————————————————————————————————–
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
    —————————————————————————————————————–
    99 | WARNING | Global with anything other than bare variables is discouraged since PHP 7.0. Found ${$settings}
    115 | WARNING | Global with anything other than bare variables is discouraged since PHP 7.0. Found ${$settings}
    —————————————————————————————————————–

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jeff Starr

    (@specialk)

    Thanks for reporting. The post title says “errors”, but there are none, only warnings. Nonetheless I will investigate and resolve for the next plugin update. Feel free to post again with any further infos, feedback, etc.

    Shaun Roselt

    (@shaunroseltgmailcom)

    I said errors because it could turn into a possible future error in upcoming PHP versions, but you’re 100% correct.

    Right now it’s just warnings.

    Shaun Roselt

    (@shaunroseltgmailcom)

    Hi. Any news on this?

    Plugin Author Jeff Starr

    (@specialk)

    Currently working on plugin updates, should be getting to this soon.

    Shaun Roselt

    (@shaunroseltgmailcom)

    Okay thanks.

    Plugin Author Jeff Starr

    (@specialk)

    Just to follow up with this, the reported code is updated for latest PHP in the upcoming version. Should be available soon. Thanks again for the feedback, Shaun.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.