Support » Plugin: All-in-One Event Calendar » Errors since update

  • Resolved raneyron

    (@raneyron)


    Using WordPress 5
    Catch Box Theme 4.8.1

    I’m having issues with editing pages. The error message:
    Parse error: syntax error, unexpected '[' in /home/content/84/9906484/html/wp/wp-content/plugins/all-in-one-event-calendar/app/model/event/instance.php on line 151

    Clearly, it has to do with this plugin. I updated the plugin last night, if I am correct. If I disable the plugin, I am able to edit pages again.

    Please advise.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Benjamin

    (@bsokic)

    Hi @raneyron,

    Do you know which PHP version your host is running?

    Thanks,
    Ben

    ncdesignz

    (@ncdesignz)

    I didn’t want to start a new thread, since I am getting an editing error, also. Mine only occurs on Events, when I create or update any event…this is the error I get:

    The link you followed has expired.

    Please try again.

    When I click “Please try again.” it appears to then work.

    We are using PHP7, and the latest version of WordPress (5.0.2).

    Thank you!

    Same error here..
    Parse error: syntax error, unexpected ‘[‘ in /home/content/08/14044108/html/wp-content/plugins/all-in-one-event-calendar/app/model/event/instance.php on line 151

    WordPress 5.0.2 running Atahualpa theme.
    PHP Version 5.3

    Same here:

    Parse error: syntax error, unexpected ‘[‘ in /www/htdocs/hijmanon/wp-content/plugins/all-in-one-event-calendar/app/model/event/instance.php on line 151

    PHP: 5.3.29
    WordPress: 5.02
    calendar: both 2.5.35 and 2.5.36

    Previous events are no longer displaying in the frontend AND backend, they do exist in the events.sql database though.
    Help much appreciated
    Sincerely
    Ron

    Same here:

    Parse error: syntax error, unexpected ‘[‘ in /home/content/11/11852611/html/wordpress/wp-content/plugins/all-in-one-event-calendar/app/model/event/instance.php on line 151

    PHP 5.3
    calendar works great with 2.5.32 but shows this error with 2.5.36, not sure about other versions in between

    The parse error is related to the PHP version used. Minimum should be 5.4
    I’ve upgraded the hosting server tot PHP 7 and that solved the problem.
    Contact your hosting provider is needed to update your PHP version.
    Sincerely
    Ron

    Thanks everyone. If I decide to use this plugin again, I will look into updating PHP on our shared host, if possible.

    Thanks, Ron. Had to upgrade to a new server and migrate the site, but PHP 7.2 fixed it.

    Thorworx

    (@thorworx-1)

    <moved>

    • This reply was modified 10 months ago by Thorworx. Reason: Moved to new thread
Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Errors since update’ is closed to new replies.