• Resolved wizardqptz

    (@wizardqptz)


    I have an error on the website:

    Warning: preg_match_all (): Compilation failed: UTF-8 error: byte 2 top bits not 0x80 at offset 48 in /home/…/wp-content/plugins/internal-links/core/linkbuilder.php on line 161

    The settings are the default. Can I ask for tips where is the problem?

    Plugin version 2.0.1

    access to page: dev/dev

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Internal Links

    (@internallinkjuicer)

    Thanks for getting in touch. Unfortunately, we are not able to replicate the issue.

    For now, it does not seem to harm the index building but we’ll be working further on this.

    I will keep you updated here in this thread.

    Thread Starter wizardqptz

    (@wizardqptz)

    This is a very important bug because it prevents us from using the plugin. The preg_match_all() function does not work properly and it may behave differently depending on the server. The site is on Linux / LiteSpeed and it’s not working, and my localhost on Apache works great here.

    I’m sending more data:

    • Linux server architecture 3.10.0-962.3.2.lve1.5.28.el7.x86_64 x86_64
    • LiteSpeed web server
    • Tested on PHP 7.3 / 7.4 / 8.0

    can it be additionally connected with Unicode characters (eg Polish characters ó ł ę ą ą etc)?

    error is in plugins/internal-links/core/linkbuilder.php on line 161
    preg_match_all( ‘/’ . Encoding::maskPattern( $pattern ) . ‘/ui’, $content, $rule_match );

    Please verify it again – this is a really important bug 🙁

    Plugin Contributor Internal Links

    (@internallinkjuicer)

    Thanks for the update. We are already working on the issue and trying to replicate the problems here on our end.

    Plugin Contributor Internal Links

    (@internallinkjuicer)

    I appreciate your patience.

    Our team tried our best to replicate the issue, we also tried running the same LiteSpeed server and different PHP settings but we were not able to replicate the issue.

    We apologize but we have tried everything and really took time on working on this issue. We are unable to fix it because we cannot replicate and find the actual root of the warning.

    It might be related to content issues or other characters that were unable to decode properly. We have also tried your site contents itself to see if that would be the case but still no errors on our part.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Errors preg_match_all’ is closed to new replies.