Support » Plugin: Duplicate Post » Errors on top screen

  • Resolved poylar

    (@poylar)


    Deprecated: Required parameter $areWePro follows optional parameter $taxonomies in C:\OpenServer\domains\ele\wp-content\plugins\copy-delete-posts\post\handler.php on line 322
    
    Deprecated: Required parameter $site follows optional parameter $isChild in C:\OpenServer\domains\ele\wp-content\plugins\copy-delete-posts\post\handler.php on line 503
    
    Deprecated: Required parameter $destination follows optional parameter $path in C:\OpenServer\domains\ele\wp-content\plugins\copy-delete-posts\post\handler.php on line 677
    
    Warning: Cannot modify header information - headers already sent by (output started at C:\OpenServer\domains\ele\wp-content\plugins\copy-delete-posts\post\handler.php:322) in C:\OpenServer\domains\ele\wp-admin\includes\misc.php on line 1380
    
    Warning: Cannot modify header information - headers already sent by (output started at C:\OpenServer\domains\ele\wp-content\plugins\copy-delete-posts\post\handler.php:322) in C:\OpenServer\domains\ele\wp-includes\functions.php on line 6878
    
    Warning: Cannot modify header information - headers already sent by (output started at C:\OpenServer\domains\ele\wp-content\plugins\copy-delete-posts\post\handler.php:322) in C:\OpenServer\domains\ele\wp-admin\admin-header.php on line 9

    WP 6.0
    Custom thme underscore ,
    no setting/ no others plugins

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author iClyde

    (@iclyde)

    Hi @poylar

    It looks like a warning of PHP 8 or PHP 8.1.
    The issue is confirmed and will be resolved in upcoming release.

    In any case, this is only deprecated notice and shouldn’t affect functionality of the plugin 🙂

    Last three warnings are related to enabled debug mode which most likely produced deprecated output causing issues with headers, future version should resolve it as well – if it’s urgent for you to hide it, you can simply disable WP_DEBUG_DISPLAY in your wp-config.php.

    Thank you for reporting!

    These notices make it challenging to develop a site with your plugin activated. Yes, they’re deprecations, but PHP 8.0 was released in 2020. 🙂 It’s time to update the plugin.

    Plugin Author iClyde

    (@iclyde)

    Hi @joshf

    If you really need that fix instantly, you can use this beta version:
    Download: https://backupbliss.com/downloads/plugins/bmi-betas/backup-backup-1.2.1.3.zip

    As I said before, it does not affect functionality of this plugin in any way.
    It’s just a standard which helps creating automatic documentation and code auto-completing.

    Update for that will be soon, in upcoming version 🙂

    I agree that these notices aren’t as important in production, but it makes developing a site (with WP_DEBUG intentionally enabled) quite difficult as every admin screen is affected and essentially broken.

    Thanks for the link! I’ll give it a go.

    Plugin Author iClyde

    (@iclyde)

    Hi @joshf

    Sure thing, but you can still hide only deprecated messages if needed.
    Here’s detailed guide how to do it in many ways: https://stackoverflow.com/a/5651783

    ini_set("error_reporting", E_ALL & ~E_DEPRECATED);
    But I recommend to use php.ini for that.

    Hope that will help in future 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.