Support » Plugin: Zedna Custom Dashboard Messages » errors on admin screens

  • Resolved wilderbee

    (@wilderbee)


    This plugin was updated barely a month ago in November, all was good. But now with theme and all else updating to match the WordPress 5.6.0 release, warning messages appear on the admin screens. The errors do not show on the public view, only on the admin screens, and usually prevents them from reloading. All admin screens, not just the main dashboard.

    When I deactivate this plugin the errors go away, thus I am reporting to you. I hope this can be fixed as I really like this plugin.
    Here are the warning messages:
    Warning: array_flip() expects parameter 1 to be array, null given in /home/xxxxxxxx/public_html/wp-admin/includes/menu.php on line 280
    Warning: Cannot modify header information – headers already sent by (output started at /home/xxxxxxxx/public_html/wp-admin/includes/menu.php:280) in /home/xxxxxxxx/public_html/wp-includes/functions.php on line 6360
    Warning: Cannot modify header information – headers already sent by (output started at /home/xxxxxxxx/public_html/wp-admin/includes/menu.php:280) in /home/xxxxxxxx/public_html/wp-admin/includes/misc.php on line 1310
    Warning: Cannot modify header information – headers already sent by (output started at /home/xxxxxxxx/public_html/wp-admin/includes/menu.php:280) in /home/xxxxxxxx/public_html/wp-admin/admin-header.php on line 9

    Thank you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Radek Mezulanik

    (@zedna)

    Hi @wilderbee,
    i´m glad you like the plugin.
    Can you please provide more details? I can see the error is coming from WP Core files, not straight from plugin. Did you try to disable all the other plugins and switch to default template? I´m using this plugin on ~8 websites and various hostings and i´m not experiencing these errors.

    Thread Starter wilderbee

    (@wilderbee)

    Yes I have disabled other plugins one by one but only disabling this plugin clears the errors. Those errors return instantly when I re-enable this plugin.

    I also tried switching to twenty-twenty theme but errors persist, disappear when disabling this plugin, then reappear when enabled again.

    Calling this Host#1:
    WordPress 5.6.0
    Database Version 10.3.27-MariaDB
    PHP version 7.4.11
    Not multisite

    This plugin is working on a second site, on a completely different host, with the same theme and mostly the same plugins with no issue:
    Calling this Host#2:
    WordPress 5.6.0
    Database Version 5.7.32
    PHP version 7.4.13
    Not multisite

    This plugin is also working on a third site, at Host#1 but on a different server. It is a multisite. Same theme and mostly the same plugins. HOWEVER, this site will Not be updated to WP 5.6.0 until there is time for potential consequences of one tender plugin unique to that site. Hopefully there will be a solution to this item before I get that far ….

    Thank you!

    Plugin Author Radek Mezulanik

    (@zedna)

    Hi @wilderbee i´ve released a fix for this.

    Thread Starter wilderbee

    (@wilderbee)

    Update to 2.2.2 is working Perfectly.
    Great plugin for sharing site notes with admins.
    Thank you!

    Plugin Author Radek Mezulanik

    (@zedna)

    solved

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.