Support » Plugin: Disable Emojis » Errors/Issues with Scan for PHP 7.0 Compatibility

  • I ran a Compatibility Scan with this plugin – PHP Compatibility Checker by WP Engine – before upgrading to PHP 7.0and the report found the following:

    Name: Disable Emojis
    
    FILE: /home/neotech2/public_html/wp-content/plugins/disable-emojis-littlebizzy/admin-notices-ms.php
    -----------------------------------------------------------------------------------------------------------
    FOUND 2 ERRORS AFFECTING 2 LINES
    -----------------------------------------------------------------------------------------------------------
     85 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
     86 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    -----------------------------------------------------------------------------------------------------------
    
    FILE: /home/neotech2/public_html/wp-content/plugins/disable-emojis-littlebizzy/emojis/filters.php
    -----------------------------------------------------------------------------------------------------------
    FOUND 2 ERRORS AFFECTING 2 LINES
    -----------------------------------------------------------------------------------------------------------
     57 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
     58 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    -----------------------------------------------------------------------------------------------------------
    
    FILE: /home/neotech2/public_html/wp-content/plugins/disable-emojis-littlebizzy/emojis/emojis.php
    -----------------------------------------------------------------------------------------------------------
    FOUND 1 ERROR AFFECTING 1 LINE
    -----------------------------------------------------------------------------------------------------------
     25 | ERROR | Using a call-time pass-by-reference is deprecated since PHP 5.3 and prohibited since PHP 5.4
    -----------------------------------------------------------------------------------------------------------

    Do you need to address these before I upgrade to 7.0?

    • This topic was modified 10 months, 1 week ago by  neotechnomad.

    The page I need help with: [log in to see the link]

  • The topic ‘Errors/Issues with Scan for PHP 7.0 Compatibility’ is closed to new replies.