Support » Plugin: Amazon Associates Link Builder » Errors in Templates settings page

  • Resolved veleno

    (@veleno)


    I get two errors in Template settings page.
    This notice is shown in the template name field when I first open the page:
    <br /><b>Notice</b>: Undefined variable: aalb_template_name in <b>/www/carlo_406/public/wp-content/mydir/plugins/amazon-associates-link-builder/admin/sidebar/partials/aalb_templates.php</b> on line <b>175</b><br />

    If I save settings, I get this error message:
    WordPress database error: [Table ‘wordpress.wp_options’ doesn’t exist]
    DELETE from wp_options WHERE option_name like ‘_transient_timeout_aalb%ProductCarousel%’ or option_name like ‘_transient_aalb%ProductCarousel%’

    Thanks
    Carlo

Viewing 3 replies - 1 through 3 (of 3 total)
  • I’ve found that the plugin does not work properly when table prefix is other than wp_. I’ve found a number of queries like the following one:

    DELETE from wp_options
    WHERE option_name like %s or option_name like %s'

    The plugin works properly just in case the table prefix is wp_.

    Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Hi veleno,
    Thanks for your feedback. You are right that the plugin assumes wordpress table prefix to be “wp_”. This will be fixed in the next plugin update.

    Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    The issue has been fixed with latest update. Please update to v1.3.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Errors in Templates settings page’ is closed to new replies.