Support » Theme: Astra » Errors in Appearance > Widgets section

  • I went into Appearance > Astra Options and clicked on Settings for Astra Widgets and I see a lot of errors. The same errors are there when I just go straight into Widgets. How can I upload an image of the errors I am seeing and the errors in the console? Where do you load images that you can link to?

    In the Widgets area the errors reference a block type (like “text” and all have

    The “text” block was affected by errors and may not function properly. Check the developer tools for more details.

    It would take too long to show all the errors and warnings that I am getting from the console, and the warnings are being logged by Query Monitor.

    For the warnings, I am seeing “PHP errors in AJAX response”.

    For the errors I am seeing “Failed to load resource: the server responded with a status of 500 ()” and they are pointing to a lot of different min.js files: in wp-json (?), in wp-includes, a jquery, and a bunch of Google files which is probably from something else.

    Any idea how to get the Widgets area working? I have some screenshots I can upload if they would be helpful.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Alex

    (@expofield)

    I have a similar issue, however it doesn’t appears as error, but it notifies me that this particular page doesn’t support the widgets area. It shows it everywhere – doesn’t matter whether I am in a page with a sidebar or not.

    Thread Starter Jim

    (@kernix)

    Right now, the widgets area is unusable.

    Alex

    (@expofield)

    Mine, too!

    Alex

    (@expofield)

    I’m on my way to cry…

    Widget area totally broke!

    > https://prnt.sc/26keo0g

    It doesn’t accept me adding widgets, actually it is but it arrange them in columns!

    :(:(:(….

    Thread Starter Jim

    (@kernix)

    Right-click > Inspect then click the Console tab to view the errors. I actually scrolled further down and then I see the widgets so it is usable.

    I’m helping someone else speed up their site and do some design work. They obviously have the Astra theme, but they also have the following:

    Under Appearance, they have Starter Templates and Astra Options.
    In Plugins, they have Astra Widgets.

    Do you have any of those? I removed 14 plugins:

    Accelerated Mobile Pages
    Advanced Database Cleaner
    Charts Blocks for Gutenberg
    Google Listings and Ads
    HandL UTM Grabber
    Jetpack
    No Self Pings
    SmartCrawl
    Structured Content
    Tracking Code Manager
    W3 Total Cache
    WP Dashboard Notes
    WP First Letter Avatar
    WP Review

    I wondering if removing “Charts Blocks for Gutenberg” is the cause. The plugin “Structured Content” is suspect as well, but I do not know what they do. I asked the owners if they knew what the plugins were for and if they were using them – they said no on both accounts.

    When I go to Appearance > Astra Options > Astra Widgets and then click Settings, it takes me into the widgets area where the red panels with the errors are displayed.

    Here is a screenshot

    Alex

    (@expofield)

    I do not have none of those.

    I have one error in my console:

    > Audit usage of navigator.userAgent, navigator.appVersion, and navigator.platform

    No other errors for the moment, but that must be a big ERROR as everything broken!

    Check in the error_logs files – those of WordPress, and those of the admin as well.

    You could find something there.

    Alex

    (@expofield)

    Okay, I found out why my sidebar is broken.

    You should focus on the widget area plugins.

    However, I have other issues surely related to the theme as I deinstalled all the plugins and they are still there.

    Hi @kernix, @expofield,

    How can I replicate this? All is fine on my end. Refer to this screenshot, please.

    Looking forward to hearing from you guys.

    Kind regards,
    Herman 🙂

    Thread Starter Jim

    (@kernix)

    I have no idea how you would replicate it because I don’t know why it is happening.

    Hi @kernix,

    If you are still facing the issue, please consider reaching out to us thru our Support Portal so we can have a closer look at the issue.

    Kind regards,
    Herman 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Errors in Appearance > Widgets section’ is closed to new replies.