Support » Installing WordPress » Errors from MySQL During Installation

  • I keep getting WordPress errors with SQL when I try to install. all of the errors are similar to the one below. Any help would be appreciated.


    WordPress database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘/wpmu_categories ( cat_ID int(4) NOT NULL auto_increment, c]
    CREATE TABLE wp_/wpmu_categories ( cat_ID int(4) NOT NULL auto_increment, cat_name varchar(55) NOT NULL default ”, category_nicename varchar(200) NOT NULL default ”, category_description text NOT NULL, category_parent int(4) NOT NULL default ‘0’, PRIMARY KEY (cat_ID), UNIQUE KEY cat_name (cat_name), KEY category_nicename (category_nicename) )

Viewing 10 replies - 1 through 10 (of 10 total)
  • wp_/wpmu

    it looks like you have a slash in the ‘table prefix’ part of your wp-config.php file. Make sure it’s just wp_ there, and retry.

    I see what you’re saying but I cannot find a reference anywhere that includes the ‘/’ that is being added. It’s not in the wp-config.php file and i haven’t been able to find it in any of the other files.

    Strange. It also seems that you’re installing WP-MultiUser, is this right?

    The slash is your problem, it’s in there somewhere.

    Yes, I’m trying WP-MultiUser. I unzipped the files locally and did a global search on all the files looking for “wp_/” and it turned up nothing.

    look for “CREATE TABLE” statements, and see if anything is goofy in that general region. Start with upgrade-schema.php in wp-admin.

    I have found nothing goofy with the create table statements.

    table prefix isn’t in wp-config.php, it appears to be dynamically set based on the url used in wpmu-settings.php (line 28). The default installation presumes that you have installed wpmu into a directory that resolves to if that isn’t true you may need to edit wpmu-settings.php

    (note: this is after 15 minutes of looking at the tarball and doing one quick install with no errors. I could be completely wrong)

    I removed all of the wpmu files and tried again (starting all the way at downloading the .zip file and decompressing it again). This time I did something different than last time. Last time I manually edited the config file. This time I did something else. I don’t remember which page I opened first but I opened a page which started a wizard of sorts and that stepped me through everything. After doing it this way it worked. Now all I need to do is figure out how to create multiple blogs.

    Hi! How you managed to resolve this error. I keep getting that error at the end of installation.

    I installed several times getting a series of errors. At this point I can get to the admin page if I enter the url: but not if I enter

    and if I hit the main site it get some type of infinite loop. This shows up in my logs: – – [21/Feb/2005:18:57:03 -0500] “GET /index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php/index.php HTTP/1.1” 302 1138 “-” “Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)”

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Errors from MySQL During Installation’ is closed to new replies.