Support » Plugin: Security Ninja - Secure Firewall & Secure Malware Scanner » Errors and warnings still appear after configuration

  • Resolved tamarazambrana

    (@tamarazambrana)


    Hi,

    Even if I follow the instructions to get everything in order, I still get a warning as if the configuration is wrong. But I’ve deleted the files and configured funcions.php, wp-config.php and .htaccess. How can I make the warnings disappear? (of course I repeated the scan)

    Warnings:
    Check if full WordPress version info is revealed in page’s meta data.
    Check if readme.html file is accessible via HTTP on the default location.
    Check if license.txt file is accessible via HTTP on the default location.
    Check if uploads folder is browsable by browsers.
    Check if admin interface is delivered via SSL

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Lars Koudal

    (@lkoudal)

    Hello tamarazambrana

    Thank you for writing to us – If you have followed the instructions for fixing those tests you mention, they should disappear.

    I can only think some tests would not work properly if it was a local site you are working on?

    “Check if full WordPress version info is revealed in page’s meta data.”
    This could be if the theme has the version info hard-coded into the theme template.

    “Check if readme.html file is accessible via HTTP on the default location.”
    If you have deleted the file via FTP, it should not show up anymore?

    “Check if license.txt file is accessible via HTTP on the default location.”
    If you have deleted the file via FTP, it should not show up anymore?

    If there is a cache plugin installed that could perhaps influence the results, but that is less likely.

    Do you see a “failed” next to the tests or a “Warning”? Warning can be if the plugin cannot programmatically detect the change you made.

    • This reply was modified 4 months, 2 weeks ago by Jan Dembowski.
    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    Excuse me @tamarazambrana while I do some forum moderation and be off topic.

    @lkoudal You had previously asked for admin access and that’s not allowed.

    https://wordpress.org/support/topic/skip-button-for-freemius-upsell-doesnt-work/?view=all#post-11936583

    Don’t ask users to contact you off site. Help your users here. I deleted that portion from your reply.

    @lkoudal It’s not at localhost but it’s a deployment environment, is protected with an username and password in .htaccess. Maybe this can show ‘false’ error messages too?

    Plugin Contributor Lars Koudal

    (@lkoudal)

    Hello @tamarazambrana – Yes, that would be the cause then. The plugin gets an unexpected result since it is not prepared for entering a username and password.

    Once you open up for the website, the errors will disappear.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.