Support » Plugin: WP Super Cache » Errors after WP update to 5.3

  • Resolved michaelkallweitt

    (@michaelkallweitt)


    After updating WordPress to 5.3 I get these error messages both in the dashboard, and on my site. However, I don’t remember installing WP super cache, nor can I find it in the plugins.

    Warning: include_once(/home/sites/site12/web/wp-content/plugins/wp-super-cache/wp-cache-phase1.php): failed to open stream: No such file or directory in /home/sites/site100004872/web/wp-content/advanced-cache.php on line 22

    Warning: include_once(): Failed opening ‘/home/sites/site12/web/wp-content/plugins/wp-super-cache/wp-cache-phase1.php’ for inclusion (include_path=’.:/usr/share/php7:/usr/share/php’) in /home/sites/site100004872/web/wp-content/advanced-cache.php on line 22

    Warning: Declaration of Custom_Menu_Wizard_Walker::walk($elements, $max_depth) should be compatible with Walker::walk($elements, $max_depth, …$args) in /home/sites/site100004872/web/wp-content/plugins/custom-menu-wizard/include/class.walker.php on line 0

    Warning: Declaration of Custom_Menu_Wizard_Sorter::walk($elements, $max_depth = 0) should be compatible with Walker::walk($elements, $max_depth, …$args) in /home/sites/site100004872/web/wp-content/plugins/custom-menu-wizard/include/class.sorter.php on line 0

    Warning: Cannot modify header information – headers already sent by (output started at /home/sites/site100004872/web/wp-content/advanced-cache.php:22) in /home/sites/site100004872/web/wp-includes/functions.php on line 5946

    Warning: Cannot modify header information – headers already sent by (output started at /home/sites/site100004872/web/wp-content/advanced-cache.php:22) in /home/sites/site100004872/web/wp-admin/includes/misc.php on line 1252

    Warning: Cannot modify header information – headers already sent by (output started at /home/sites/site100004872/web/wp-content/advanced-cache.php:22) in /home/sites/site100004872/web/wp-admin/admin-header.php on line 9

Viewing 6 replies - 1 through 6 (of 6 total)
  • michaelkallweitt

    (@michaelkallweitt)

    OK, after I manually installed WP Super Cache, the errors are still there.

    My site URL is https://www.wasfuereintheater.com/

    Can someone help me to fix it?

    Hi,
    I also get this error message since the last WordPress update 5.3 and can no longer log in:

    Warning: include_once (/www/htdocs/w00d04f7/blog/wp-content/plugins/wp-super-cache/wp-cache-phase1.php): failed to open stream: No search file or directory in / www / htdocs / w00d04f7 / blog / wp-content / advanced-cache.php on line 8

    Warning: include_once (): Failed opening ‘/www/htdocs/w00d04f7/blog/wp-content/plugins/wp-super-cache/wp-cache-phase1.php’ for inclusion (include_path = ‘.: / Usr / share / php: .. ‘) in /www/htdocs/w00d04f7/blog/wp-content/advanced-cache.php on line 8

    Warning: Can not modify header information – headers already sent by (output started at /www/htdocs/w00d04f7/blog/wp-content/advanced-cache.php:8) in / www / htdocs / w00d04f7 / blog / wp-login. php on line 496

    Warning: Can not modify header information – headers already sent by (output started at /www/htdocs/w00d04f7/blog/wp-content/advanced-cache.php:8) in / www / htdocs / w00d04f7 / blog / wp-login. php on line 512

    Warning: Can not modify header information – headers already sent by (output started at /www/htdocs/w00d04f7/blog/wp-content/advanced-cache.php:8) in / www / htdocs / w00d04f7 / blog / wp-includes / functions.php on line 5946

    Warning: Can not modify header information – headers already sent by (output started at /www/htdocs/w00d04f7/blog/wp-content/advanced-cache.php:8) in / www / htdocs / w00d04f7 / blog / wp-includes / pluggable.php on line 932

    Warning: Can not modify header information – headers already sent by (output started at /www/htdocs/w00d04f7/blog/wp-content/advanced-cache.php:8) in / www / htdocs / w00d04f7 / blog / wp-includes / pluggable.php on line 933

    Warning: Can not modify header information – headers already sent by (output started at /www/htdocs/w00d04f7/blog/wp-content/advanced-cache.php:8) in / www / htdocs / w00d04f7 / blog / wp-includes / pluggable.php on line 934

    Warning: Can not modify header information – headers already sent by (output started at /www/htdocs/w00d04f7/blog/wp-content/advanced-cache.php:8) in / www / htdocs / w00d04f7 / blog / wp-includes / pluggable.php on line 1265

    Warning: Can not modify header information – headers already sent by (output started at /www/htdocs/w00d04f7/blog/wp-content/advanced-cache.php:8) in / www / htdocs / w00d04f7 / blog / wp-includes / pluggable.php on line 1268

    How can I fix this?

    michaelkallweitt

    (@michaelkallweitt)

    It might help to visit the file system of your WP installation, and remove the wp-super-cache directory from /wp-contents/plugins/

    In my case (I could still log in), I manually installed the plugin from the dashboard, then disabled caching in the settings.

    Thanks for your help.
    That was my first thought too.
    But (although I had super-cache installed) there is no wp-super-cache folder in the plugin folder.
    There is a separate cache folder with an empty supercache subfolder.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Basically, you deleted the plugin when you updated and did so incorrectly.

    When you remove a caching plugin, you also need to remove the /wp-content/advanced-cache.php file along with it.

    @krowb53 This is somebody else’s thread, please start your own topic for your own unrelated problems.

    Thank you very much for the help.
    Sometimes this solution to the problem is quite simple.
    And sorry, for the incorrect placement of my question. I will pay attention to it in the future.
    Have a nice day!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.