WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Errors after upgrading from 2.3 to 2.5

[Resolved] Errors after upgrading from 2.3 to 2.5

  • I just upgraded to 2.5 for the installation used to demo wordpress themes on themebot.com. The frontend appears to be working fine. However, when I log in to the backend I get the following errors:

    Dashboard:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 7680 bytes) in /public_html/wordpress-2x/wp-includes/kses.php(898) : runtime-created function on line 1

    Design Tab:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 7680 bytes) in /public_html/wordpress-2x/wp-includes/kses.php(396) : regexp code on line 1

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Hah! That bit of code looks somewhat insane to me.

    What exactly were you posting/doing to trigger that error?

    I just finished re-uploading the installation in case something got fudged during the first upload. Still seeing the error.

    There’s a bunch of themes loaded, almost 1500 themes that have been uploaded by members. I wonder if 2.5 is trying to list all the themes and choking. This wasn’t a problem in 2.3.

    You need to allocate more memories to wordpress/php.
    Try to see if this helps.

    You need to allocate more memories to wordpress/php.

    Thanks. I increased the memory allocated to 96M. The dashboard and design sections load now. However, it takes almost a minute to see the dashboard when loggging in. Chug chug chug.

    I also am having issues on the admin side only. All is well on the outside…. (well I think it is).

    ANYHOOOOOO when attempting to post none of the posting pages will load without errors. I am a newb but running a pretty clean version of wordpress. Which is why I figured oh sure go ahead and follow that upgrade procedure.

    What do you mean there is no UNDO?

    Always make complete backups before upgrading. Then there is an undo 😀

    I got the back up… I am just terrified of making it worse and looking for answers here first. Thanks tho…
    Which by the way I shoulda done BEFORE even considering the upgrade.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Errors after upgrading from 2.3 to 2.5’ is closed to new replies.