Support » Plugin: Download Manager » Errors after update to v3.0.98

  • Resolved Ed

    (@eammendola)


    Here are the two warnings I am getting in the USER EDIT dialogue:

    (!) Warning: include(C:\wamp64\www\intranet\wp-content\plugins\download-manager/admin/tpls/edit-store-profile.php): failed to open stream: No such file or directory in C:\wamp64\www\intranet\wp-content\plugins\download-manager\libs\class.User.php on line 112
    Call Stack
    # Time Memory Function Location
    1 0.0003 430352 {main}( ) …\user-edit.php:0
    2 2.7869 28159800 do_action( ) …\user-edit.php:725
    3 2.7869 28160176 WP_Hook->do_action( ) …\plugin.php:478
    4 2.7869 28160176 WP_Hook->apply_filters( ) …\class-wp-hook.php:311
    5 2.7869 28161168 WPDM\libs\User->shopProfile( ) …\class-wp-hook.php:287

    (!) Warning: include(): Failed opening ‘C:\wamp64\www\intranet\wp-content\plugins\download-manager/admin/tpls/edit-store-profile.php’ for inclusion (include_path=’.;C:\php\pear’) in C:\wamp64\www\intranet\wp-content\plugins\download-manager\libs\class.User.php on line 112
    Call Stack
    # Time Memory Function Location
    1 0.0003 430352 {main}( ) …\user-edit.php:0
    2 2.7869 28159800 do_action( ) …\user-edit.php:725
    3 2.7869 28160176 WP_Hook->do_action( ) …\plugin.php:478
    4 2.7869 28160176 WP_Hook->apply_filters( ) …\class-wp-hook.php:311
    5 2.7869 28161168 WPDM\libs\User->shopProfile( ) …\class-wp-hook.php:287

    DM v3.0.98 is referring to a file that does not exist in v3.0.97 or v3.0.98.
    File: class.User.php v3.0.98 line 112 -> include WPDM_BASE_DIR.”admin/tpls/edit-store-profile.php”;

    Please provide a fix!
    Thanks.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • khaleeldeli

    (@khaleeldeli)

    After todays (June 23, 2020) update it get fatal error

    Parse error: syntax error, unexpected ‘::’ (T_PAAMAYIM_NEKUDOTAYIM) in
    public_html/wp-content/plugins/download-manager/libs/class.CategoryHandler.php on line 299

    Plugin Support Nayeem Hyder

    (@nriddhi)

    Please check if you are using outdated PHP version, this also causes this

    Thanks

    guideloom

    (@guideloom)

    We have the exact same issue. We are running PHP 7.4.
    The error is obvious. The application is trying to reference a file that IS NOT INCLUDED IN VERSION 3.0.98.

    (Note: Pathnames below redacted)

    Warning: include(xxxxx/public/wp-content/plugins/download-manager/admin/tpls/edit-store-profile.php): failed to open stream: No such file or directory in xxxxx/public/wp-content/plugins/download-manager/libs/class.User.php on line 112

    Warning: include(): Failed opening ‘xxxxx/public/wp-content/plugins/download-manager/admin/tpls/edit-store-profile.php’ for inclusion (include_path=’.:/opt/sp/php7.4/lib/php’) in xxxxx/public/wp-content/plugins/download-manager/libs/class.User.php on line 112

    edit-store-profile.php does not exist.

    • This reply was modified 2 years ago by guideloom.
    • This reply was modified 2 years ago by guideloom.
    khaleeldeli

    (@khaleeldeli)

    Thanks. After PHP updation, the problem has been fixed

    Thread Starter Ed

    (@eammendola)

    khaleeldeli (@khaleeldeli) and Nayeem Hyder (@nriddhi)

    Please do not hijack other people’s support thread. khaleeldeli, your issue is entirely different than what I (and some others are experiencing). Our issue has nothing to do with PHP version. The response to your question makes it look like my issue is resolved, which it is not. Have some respect for other people, okay?

    This is the problem —>>> edit-store-profile.php does not exist.

    khaleeldeli

    (@khaleeldeli)

    I’m sorry for my last update on this topic. Even if my issue related ‘Errors after update’, it is different from the creator of this topic. Actually the creator of this topic “Ed (@eammendola)” need a solution. Kindly contribute to find a perfect solution for him.

    Thread Starter Ed

    (@eammendola)

    Still waiting for a fix. The last update to v3.0.98 is defective.

    Plugin Contributor Shafaet Alam

    (@shafayat-alam)

    Hi,
    Sorry for the delays, a new update is coming within the next few hours.

    Plugin Contributor Shafaet Alam

    (@shafayat-alam)

    The update is available now.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Errors after update to v3.0.98’ is closed to new replies.