Support » Plugin: Redis Object Cache » Errors

  • Resolved Piska

    (@piska)


    Hallo,
    Could you have a look at my errors?
    Thanks in advance!
    My error logs contain this:

    [Wed Oct 28 03:22:03.932721 2020] [lsapi:notice] [pid 117193:tid 140623782676224] [client 13.48.9.24:29307] [host ] Backend log: RedisException: read error on connection to 10.0.24.1:22422 in /home/11111112/domains/domain.nl/public_html/wp-content/object-cache.php:1357\nStack trace:\n#0 /home/11111112/domains/domain.nl/public_html/wp-content/object-cache.php(1357): Redis->get(‘wp:freemius:fs_…’)\n#1 /home/11111112/domains/domain.nl/public_html/wp-content/object-cache.php(114): WP_Object_Cache->get(‘fs_cache_5860’, ‘freemius’, false, NULL)\n#2 /home/11111112/domains/domain.nl/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/freemius/includes/managers/class-fs-option-manager.php(179): wp_cache_get(‘fs_cache_5860’, ‘freemius’)\n#3 /home/11111112/domains/domain.nl/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/freemius/includes/managers/class-fs-option-manager.php(101): FS_Option_Manager->load()\n#4 /home/11111112/domains/domain.nl/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/freemius/includes/managers/class-fs-option-manager.php(141): FS_Option_Manager->__construct(‘fs_cache_5860’, true, true, false)\n#5 /home/11111112/domains/domain.nl/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/freemius/includes/managers/class-fs-cache-manager.php(40): FS_Option_Manager::get_manager(‘fs_cache_5860’, true, true, false)\n#6 /home/11111112/domains/domain.nl/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/freemius/includes/managers/class-fs-cache-manager.php(55): FS_Cache_Manager->__construct(‘fs_cache_5860’)\n#7 /home/11111112/domains/domain.nl/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/freemius/includes/class-freemius.php(400): FS_Cache_Manager::get_manager(‘fs_cache_5860’)\n#8 /home/11111112/domains/domain.nl/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/freemius/includes/class-freemius.php(2784): Freemius->__construct(‘5860’, ‘advanced-nocapt…’, true)\n#9 /home/11111112/domains/domain.nl/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/freemius/start.php(513): Freemius::instance(‘5860’, ‘advanced-nocapt…’, true)\n#10 /home/11111112/domains/domain.nl/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/advanced-nocaptcha-recaptcha.php(81): fs_dynamic_init(Array)\n#11 /home/11111112/domains/domain.nl/public_html/wp-content/plugins/advanced-nocaptcha-recaptcha/advanced-nocaptcha-recaptcha.php(108): anr_fs()\n#12 /home/11111112/domains/domain.nl/public_html/wp-settings.php(360): include_once(‘/home/u13750p50…’)\n#13 /home/11111112/domains/domain.nl/public_html/wp-config.php(94): require_once(‘/home/u13750p50…’)\n#14 /home/11111112/domains/domain.nl/public_html/wp-load.php(37): require_once(‘/home/u13750p50…’)\n#15 /home/11111112/domains/domain.nl/public_html/wp-blog-header.php(13): require_once(‘/home/u13750p50…’)\n#16 /home/11111112/domains/domain.nl/public_html/index.php(17): require(‘/home/u13750p50…’)\n#17 {main}\n

    
    
    Here’s output from the plugin diagnostics:
    

    Status: Connected
    Client: PhpRedis (v5.2.2)
    Drop-in: Valid
    Disabled: No
    Filesystem: Working
    Ping: 1
    Errors: []
    PhpRedis: 5.2.2
    Predis: Not loaded
    Credis: Not loaded
    PHP Version: 7.2.34
    Plugin Version: 2.0.15
    Redis Version: 4.0.10
    Multisite: No
    Global Prefix: “wp_”
    Blog Prefix: “wp_”
    WP_REDIS_HOST: “10.0.24.1”
    WP_REDIS_PORT: “22422”
    WP_REDIS_PASSWORD: ••••••••
    Global Groups: [
    “blog-details”,
    “blog-id-cache”,
    “blog-lookup”,
    “global-posts”,
    “networks”,
    “rss”,
    “sites”,
    “site-details”,
    “site-lookup”,
    “site-options”,
    “site-transient”,
    “users”,
    “useremail”,
    “userlogins”,
    “usermeta”,
    “user_meta”,
    “userslugs”,
    “redis-cache”,
    “blog_meta”
    ]
    Ignored Groups: [
    “counts”,
    “plugins”,
    “themes”,
    “wordfence”,
    “wordfence-ls”,
    “avada”
    ]
    Unflushable Groups: []
    Drop-ins: [
    “Redis Object Cache Drop-In v2.0.15 by Till Krüss”
    ]
    `

    Thanks in advance!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Piska

    (@piska)

    PS: The website with Redis On is slow. I am getting 503 errors Service Unavailable:
    The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

    Plugin Author Till Krüss

    (@tillkruess)

    My guess is you’re hitting a timeout, either because Redis is under heavy load and/or paging, or because of network issues?

    Have you tried running:

    
    redis-cli -h <host> -p <port> --latency
    
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.