Support » Localhost Installs » ERROR:LOCALHOST SITE DOES NOT DISPLAY IT’S CONTENT IN OTHER MACHINES OF MY LAN

  • Hey guys!!!
    I have a localhost wordpress site in XAMPP.When i try to open the site in other computers of my LAN it appears broken.Particularly,the images,the slides,the sub-pages and the theme customization are missing.It shows only the home page and without all the stuff i wrote above. I have tried many solutions from other forums but i can’t solve it.
    I hope you can help me!!It’s really urgent!!! Thank you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Almost certainly this is because you have used “localhost” in your siteaddress and wordpressaddress. Your page uses this to describe where the browser is to find css and image files etc, from your own PC this is all correct, but from other machines on the LAN it tells them to get the file from that computer and not the one with the XAMPP hosted wordpress.

    The easiest solution is:
    – make sure your XAMPP computer always has the same IP address on the LAN, and use this IP address in the siteaddress and wordpressaddress settings.

    Otherwise you can configure your XAMPP site to use the “VirtualHost” method and use a domain name in the VirtualHost config block and also in your siteaddress and wordpressaddress settings, and also add this domain name and your IP address into the “hosts” file on each computer. Relevant docs are:
    http://httpd.apache.org/docs/current/vhosts/name-based.html
    https://en.wikipedia.org/wiki/Hosts_(file)

    • This reply was modified 2 months, 3 weeks ago by  RossMitchell.

    Thank you so much for your answer!!!I changed the siteaddress and wordpressaddress from localhost to my IP address and the site opens right in other computers but it doesn’t open in my machine now!!It only shows me the home page and when i try to open the other pages from the menu it shows me this error in the image…I’m thinking that i can turn it local when i want to edit my site and when i want use it from other computers to turn it in my ip address..Is there any other solution??thank you

    It seems that your machine does not respond to its own IP address, curious.

    Only solution I can see is to use the VirtualHost method, I think this is well worth the effort.

    Yes exactly!!It does not respond to its own IP address.I can’t use the VirtualHost method because there are so many computers here and i can’t have access to all of them…Thank you so much for your help!!You solved a big part of this problem!!! 🙂 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.