Support » Plugin: Ginger - EU Cookie Law » Errore fatale all’ativazione del plugin

  • ostility

    (@ostility)



    Ciao, sto cercando di attivare il plugin (scaricato all’ultima versione) su un sito con una vecchissima versione di WordPress, che non mi è possibile aggiornare (3.1).

    Sono riuscita ad installarlo, ma all’attivazione mi compare questo messaggio di errore:

    Il plugin non può essere attivato perché genera un errore fatale.
    Parse error: syntax error, unexpected ‘[‘ in /htdocs/public/www/wp-content/plugins/ginger/common/ginger.share.data.php on line 80

    Alla riga 80 del file il codice è il seguente:

    $data_to_send = [];

    a cosa potrebbe essere dovuto?

    Grazie in anticipo

Viewing 4 replies - 1 through 4 (of 4 total)
  • xxxsimoxxx

    (@xxxsimoxxx)

    E’un problema di versione di PHP.
    $data_to_send = [];
    è sintassi per PHP >= 5.4.
    Prova a correggere con
    $data_to_send = array();

    http://php.net/manual/en/language.types.array.php

    As of PHP 5.4 you can also use the short array syntax, which replaces array() with [].

    ostility

    (@ostility)

    Grazie mille per la risposta. Ho provato a cambiare la sintassi, ma mi viene mostrato comunque il solito messaggio di errore, che però stavolta dice:

    Il plugin non può essere attivato perché genera un errore fatale.
    Parse error: syntax error, unexpected ‘)’ in /htdocs/public/www/wp-content/plugins/ginger/common/ginger.share.data.php on line 80

    Alla riga 80 c’è $data_to_send = (); al posto di $data_to_send = []; (la sintassi l’ho cambiata in tutte le righe dove compariva la vecchia), quindi le righe seguenti sono tutt così:

    $data_to_send(‘name’) = get_bloginfo(‘name’);
    // Site url
    $data_to_send(‘url’) = get_bloginfo(‘url’);
    // Wp Version
    $data_to_send(‘version’) = get_bloginfo(‘version’);
    // Language
    $data_to_send(‘language’) = get_bloginfo(‘language’);
    // Site Description
    $data_to_send(‘description’) = get_bloginfo(‘description’, ‘display’);

    Forse, a questo punto, faccio prima a chiedere di aggiornarmi la versione php sul server?

    xxxsimoxxx

    (@xxxsimoxxx)

    Oppure usando la vecchia sintassi dovrebbe essere:
    $data_to_send = array(
    “name” => get_bloginfo(‘name’),
    ….
    );
    Però un aggiornamento PHP potrebbe essere più semplice, se non è in conflitto con la versione WP.

    ostility

    (@ostility)

    Grazie ancora, ho provato anche a cambiare sintassi con l’ultima, ma continuano a saltar fuori altri errori… A questo punto provo a considerare l’opzione dell’aggiornamento di php, oppure di gestire il banner dei cookie in altro modo…

    Grazie per il supporto

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.