Support » Plugin: WooCommerce P.IVA e Codice Fiscale per Italia » V 2.0.4 Fatal error

  • Resolved woodypad

    (@woodypad)



    Salve,
    ho appena aggiornato il vostro plugin,
    lo uso da tempo non ho mai avuto problemi.
    Ma ora c’è un errore fatale!…

    Appena aggiornato il plugin alla Versione 2.0.4, la pagina si presenta con degli errori e compare la scritta che allego di seguito.

    Per favore è urgente tutto bloccato!!

    —–
    Fatal error: Uncaught Error: Call to a member function get_next_receipt_number() on null in /home/sito936/public_html/wp-content/plugins/woo-piva-codice-fiscale-e-fattura-pdf-per-italia/includes/class-wp-settings.php:289 Stack trace: #0 /home/sito936/public_html/wp-admin/includes/template.php(1365): WC_Piva_Cf_Invoice_Ita_Setting->nextnumberreceipt_element_callback(Array) #1 /home/sito936/public_html/wp-admin/includes/template.php(1324): do_settings_fields(‘wcpdf_IT_genera…’, ‘wcpdf_IT_genera…’) #2 /home/sito936/public_html/wp-content/plugins/woo-piva-codice-fiscale-e-fattura-pdf-per-italia/includes/class-wp-settings.php(190): do_settings_sections(‘wcpdf_IT_genera…’) #3 /home/sito936/public_html/wp-includes/class-wp-hook.php(298): WC_Piva_Cf_Invoice_Ita_Setting->settings_page(”) #4 /home/sito936/public_html/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters(”, Array) #5 /home/sito936/public_html/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #6 /home/sito936/public_html/wp-admin/admin.php(2 in /home/sito936/public_html/wp-content/plugins/woo-piva-codice-fiscale-e-fattura-pdf-per-italia/includes/class-wp-settings.php on line 289
    —–

    • This topic was modified 11 months ago by  woodypad.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author dot4all

    (@dot4all)

    Ciao @woodypad,
    l’ultima versione del plugin richiede l’installazione e l’attivazione del plugin Woocommerce Invoice & Packaging Slips scaricabile gratuitamente dal repository di WordPress.
    Un saluto

    woodypad

    (@woodypad)

    Ciao,
    perchè avete fatto questo?
    il vostro plugin era compatibile con molti altri plugin di fatturazione.
    Io già ne uso uno che mi permette anche di personalizzare l’aspetto della fattura.

    Penso che ci saranno moltissimi utenti con questo problema.
    Dovrò rivedere tutto e cercare altre soluzioni.
    Mi dispiace.

    Plugin Author dot4all

    (@dot4all)

    Ciao @woodypad,
    con la nuova versione abbiamo migliorato, seguendo la normativa italiana, la possibilità di generare ricevute fiscali con numerazione progressiva inserendo prefisso e definendo la quantità di numeri nel documento. Per queste attività abbiamo deciso di muoverci usando questo plugin che ci ha garantito di realizzare al meglio queste attività.
    Certo ci saranno futuri aggiornamenti e verificheremo eventualmente anche altre possibilità.
    Grazie per il feedback
    Un saluto

    woodypad

    (@woodypad)

    Ciao,
    si ok la numerazione, ma molti plugin di fatturazione, come quello che uso, la gestiscono già. Quindi penso che l’alterativa per continuare a rendere il vostro plugin compatibile anche con altri plugin è quella di avere un check per decidere di gestire o no la numerazione interna.

    Considerate che chi come me, al momento ha l’eccomerce bloccato, non potrà aspettare in futuro, ma deve cercare una alternativa velocemente.

    Grazie

    Plugin Author dot4all

    (@dot4all)

    Ciao,
    chiaramente le versioni precedenti alla 2 del nostro plugin puoi continuare ad utilizzarle senza problemi e non ti creano nessun problema, sono funzionanti.
    Se hai bisogno di una release in particolare puoi scrivermi e la rendo disponibile.
    Un saluto

    Plugin Author dot4all

    (@dot4all)

    Ho reso disponibile al download la 1.0.9 che è l’ultima utilizzabile con altri plugin di fatturazione
    Grazie e un saluto

    woodypad

    (@woodypad)

    ok grazie,
    basta cancellare l’attuale e installare la precedente?
    e andrà tutto a posto?

    Grazie

    Plugin Author dot4all

    (@dot4all)

    si la 1.0.9 è l’ultima versione rilasciata prima degli aggiornamenti sostanziali.
    Un saluto

    woodypad

    (@woodypad)

    Grazie!
    ho risolto, tutto nuovamente funzionante!

    Allora attenderò le prossime versioni compatibili.
    Grazie mille!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘V 2.0.4 Fatal error’ is closed to new replies.