Support » Plugin: WP Encrypt » Error:Challenge request failed for domain

  • marykelouw

    (@marykelouw)



    I have installed the Let’s Encrypt plugin via WordPress. I have a multisite. I have registered my account but it gives me the following error when I request it to generate a certificate: Challenge request failed for domain sports-injury-physio.com.
    I am also running All in One WP Security plugin – could this be the problem?
    Many thanks
    Maryke

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Felix Arntz

    (@flixos90)

    The reason for this is probably that your server setup prevents access to directories prefixed with a dot. Please make sure that the URL www.yourdomain.com/.well-known and its subdirectories can be accessed, in order for the plugin to work.

    marykelouw

    (@marykelouw)

    Thank you Felix, I’ll have a look.

    Hi Felix,

    I’m having a similar problem in getting “Challenge request failed for domain filemakercoder.com ”
    The strange part is that I installed three other domains and all went well. This last one gave me the error, though. Same ISP, same sequence of events in the installation. I uninstalled the entire site and re-installed including dns settings only to arrive at the same result.
    http://filemakercoder.com/.well-known/ is reachable and has the same write access settings as the other successful installs. htaccess file is also the same.
    Any ideas?

    I’m having the same issue. I re-created .htaccess to be default WordPress format and still have the issue. The directory /.well-known/ is 0755. Not sure where else too look for this setting.

    I figured out my issue, hope it helps someone. My site was redirecting (via two different methods) all traffic through https. I was getting certificate errors via https (still need to figure out what that’s about) so I think that’s what was preventing the challenge request from working correctly. After I disabled the https re-directing, it worked.

    @jas0n

    Could you be more precise please? Because I have the same problem and my rankings are now struggling

    This are my entries for all my redirects:

    .htaccess:

    RewriteEngine On

    RewriteCond %{SERVER_PORT} !=443
    RewriteRule ^(.*)$ https://gassihelden.de/$1 [R=301,L]

    wp-config.php

    define( 'WP_CONTENT_URL', 'https://gassihelden.de/wp-content' );

    My WordPress url settings:
    https://gassihelden.de
    https://gassihelden.de

    And I have set SSL in my Plesk panel for this domain.

    I have no idea why I get the challenge request and which redirect I should remove.
    Any idea?

    • This reply was modified 1 year, 10 months ago by  Chekki.

    Hey Chekki,

    you could try to set your domain to http://gassihelden.de within your WordPress URL-settings. Then try to generate a new certificate. For me it worked like this.
    After the process, I just put https back in place at the settings.
    I can’t tell why this is happening. My provider doesn’t give a lot information in the logs and the wp-encrypt-error message was somewhat not helpful.

    Editing the .htaccess-file or even changing the PHP-Version from 7.0 back to 5.6 didn’t help.

    Hi @ma_wordpressorg

    Your suggestion worked. Thank you!

    Can you explain a little more on this?

    What do you mean by “explain more”?
    Can you give us a litte bit more information, on what part you like to hear more?

    It will try to generate certificates not only for active domain in your multisite, but also for the www subdomain and for domains taken from “deleted” subsites.

    So check all your domains in the installation, and for those who are not a subdomain, like example.comm, include http://www.example.com.

    Ensure that all of these have a DNS A record pointing to your server and that this domain is served. Test that https://<your-domain.tld>/.well-known is not 404, for all of them.

    I disabled the redirection from http to https and the certificate auto renewed for another 3 months.
    The redirection still happens though, without re-enabling it.

    https://docs.bitnami.com/aws/components/apache/#how-to-force-https-for-all-applications

    disable redirection:

    cd /opt/bitnami/apache2/conf/bitnami/
    vi bitnami.conf

    Change RewriteEngine On
    to Off

    Save: :wq!

    reload apache
    sudo /opt/bitnami/ctlscript.sh restart apache

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Error:Challenge request failed for domain’ is closed to new replies.