• Resolved lydushe

    (@lydushe)


    Hi guys,
    suddenly I came to my website and when I tried to log in WP admin, I couldn ´t. Obviously because of Complianz.

    Warning: error_log() has been disabled for security reasons in /home/www/kovarina.cz/domains/aromadoteky.cz/ssl/wp-content/plugins/complianz-gdpr/functions.php on line 2843
    
    Warning: error_log() has been disabled for security reasons in /home/www/kovarina.cz/domains/aromadoteky.cz/ssl/wp-content/plugins/complianz-gdpr/functions.php on line 2844
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/www/kovarina.cz/domains/aromadoteky.cz/ssl/wp-content/plugins/complianz-gdpr/functions.php:2843) in /home/www/kovarina.cz/domains/aromadoteky.cz/ssl/wp-includes/pluggable.php on line 1355
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/www/kovarina.cz/domains/aromadoteky.cz/ssl/wp-content/plugins/complianz-gdpr/functions.php:2843) in /home/www/kovarina.cz/domains/aromadoteky.cz/ssl/wp-includes/pluggable.php on line 1358

    I disabled Complianz plugin by FTP and it works again. When I activated it back in my Admin section it is possible to work there, but the issue continues like this

    rning: error_log() has been disabled for security reasons in /home/www/kovarina.cz/domains/aromadoteky.cz/ssl/wp-content/plugins/complianz-gdpr/functions.php on line 2843
    
    Warning: error_log() has been disabled for security reasons in /home/www/kovarina.cz/domains/aromadoteky.cz/ssl/wp-content/plugins/complianz-gdpr/functions.php on line 2844
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/www/kovarina.cz/domains/aromadoteky.cz/ssl/wp-content/plugins/complianz-gdpr/functions.php:2843) in /home/www/kovarina.cz/domains/aromadoteky.cz/ssl/wp-includes/functions.php on line 6821
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/www/kovarina.cz/domains/aromadoteky.cz/ssl/wp-content/plugins/complianz-gdpr/functions.php:2843) in /home/www/kovarina.cz/domains/aromadoteky.cz/ssl/wp-admin/includes/misc.php on line 1310
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/www/kovarina.cz/domains/aromadoteky.cz/ssl/wp-content/plugins/complianz-gdpr/functions.php:2843) in /home/www/kovarina.cz/domains/aromadoteky.cz/ssl/wp-admin/admin-header.php on line 9

    I have WP 5.9.2. and Complianz 6.1.2. What is wrong? I temporarily disabled Complianz plugin 🙁

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Rogier Lankhorst

    (@rogierlankhorst)

    It sounds like a server setting disables the error_log() function. Your hosting provider will probably know more. Maybe disabling wp_debug in your wp-config.php will resolve it as well.

    Thread Starter lydushe

    (@lydushe)

    Thank you Rogier, error log is off, probably due to the lightening of the web hosting server. WP_debug hasnť resolved the issue.
    Until version 6.1.2 it worked fine. Is it possible to fix this issue?

    Plugin Contributor Rogier Lankhorst

    (@rogierlankhorst)

    Hi @lydushe,

    Nothing has changed regarding the error_log function in the plug-in, but I think there is a mistake in the translation for your language since the last version. Such a mistake triggers the error_log function, so users are alerted to the issue, and can fix the translation.

    Because the function is blocked, we do not know which string contains the typo.

    To resolve the issue: I would recommend to contact your hosting provider, and request to allow this function. While having wp_debug enabled on a live site is not recommended, it should always be possible to get messages in the logs when it’s enabled.

    When it’s enabled, the logs will show the sentence that contains the error. If you post it here, we can look it up, and ask the translator to fix it.

    Plugin Contributor Rogier Lankhorst

    (@rogierlankhorst)

    After searching through the string list, we now suspect it’s this string:

    https://translate.wordpress.org/projects/wp-plugins/complianz-gdpr/stable/cs/default/?filters%5Bterm%5D=5.5&filters%5Bterm_scope%5D=scope_any&filters%5Bstatus%5D=current_or_waiting_or_fuzzy_or_untranslated&filters%5Buser_login%5D=&filter=Apply+Filters&sort%5Bby%5D=priority&sort%5Bhow%5D=desc

    We will suggest a translation for this string, which should resolve your current notice.

    As translators sometimes make such mistakes, I recommend to fix the error_log blocking on your website, so it doesn’t cause issues when there’s another issue in the future.

    Thread Starter lydushe

    (@lydushe)

    @rogierlankhorst Thank you for your help. Version 6.14 works fine. Error log still off.

    Plugin Contributor Rogier Lankhorst

    (@rogierlankhorst)

    Yes, we removed the logs from this specific function because some people think it’s an error, while it points out translation mistakes.

    Did your hosting company fix the issue with the error_log function in the meantime? If not, let me know if you want us to contact them about the issue, so we can explain what the error_log is for, and why it’s not very practical to just block it.

    Thread Starter lydushe

    (@lydushe)

    No, my hosting company didn´t fix the issue. It burdens servers and mistakes happens all the time, so that´s why it is off.

Viewing 7 replies - 1 through 7 (of 7 total)

The topic ‘error_log() has been disabled for security reasons complianz’ is closed to new replies.