Support » Plugin: WP OAuth Server (OAuth Authentication) » “error_description”: “Grant type \”password\” not supported”

  • Resolved progressed

    (@progressed)


    I saw somebody else have this problem with an answer “I resolved the issue”… good for you! NOw the rest of the world.

    i followed this article:
    https://wp-oauth.com/documentation/how-tos/using-postman-wp-rest-api/

    I enabled the service and enabled the only grant type that is available for me “Authorization Code”.

    the following error accures:

    {
    “error”: “unsupported_grant_type”,
    “error_description”: “Grant type \”password\” not supported”
    }

    surely i am doing something wrong as it is problably not documented to do an extra step in the above article.

Viewing 2 replies - 1 through 2 (of 2 total)
  • PS: using the TYPE OAuth 2.0 and request a new access token gives me back the same result

    POST
    http://localhost/event/oauth/token/
    11:40:10.954
    Grant type “password” not supported
    11:40:10.963
    Error
    11:40:10.966

    Googled and some say to use the Client Credentials as GRANT TYPE. no luck:

    POST
    http://localhost/event/oauth/token/
    11:40:34.458
    Grant type “password” not supported
    11:40:34.463
    Error

    Plugin Author Justin Greer

    (@justingreerbbi)

    Forum Moderator

    Hi @progressed,

    Sorry for the confusion. I would like to start off by saying I believe you are doing everything correctly. The community version of the plugin does not support the password grant type. This version only supports the auth code grant type for website SSO and other HTML5 apps.

    We do offer a pro version of the plugin that supports just about every grant type for OAuth 2.0 and other OAuth 2 protocols. Please visit the plugins website in the readme.txt file to see all the other options.

    Again, sorry for the confusion. We are here to help so let me know if you have any other questions.

    Thanks,
    Justin Greer

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘“error_description”: “Grant type \”password\” not supported”’ is closed to new replies.