WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Error: “Your database is out-of-date. Please upgrade.” HELP!!

[Resolved] Error: “Your database is out-of-date. Please upgrade.” HELP!!

  • I can see my blog just fine (www.finlandforthought.net), but when I attempt to access the WP admin panel, I get this error…

    Your database is out-of-date. Please upgrade.

    If I click on “upgrade”, it attempts an upgrade but does nothing.

    I believe I’m using WP v2.0.11. My database is MySQL v5.0. And I think I’m using PHP 4.3 (I haven’t upgraded to 5.x yet at least)

    I’ve done not anything to my database or WP, it just happened all of a sudden. I tried “repairing” the db, it didn’t help.

    Please Help!!!!! Thank you!!!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You may need to proceed with manual upgrade of your WP. Here are the instructions how to complete it:

    http://codex.wordpress.org/Upgrading_WordPress

    Additionally you may check also the extended one:

    http://codex.wordpress.org/Upgrading_WordPress_Extended

    You should make sure that you have create proper backup of your application before proceeding with the upgrade.

    Best Regards
    [sig moderated]

    Well looking at the source on your main pages says version 2.1.3.

    Hi all and thanks for the help!

    I manually upgraded from v2.1.3 (thanks MichaelH) to v2.3. The upgrade appeared to go just fine, however I still receive this message… (http://www.finlandforthought.net/wp-admin/upgrade.php)

    Database Upgrade Required
    
    Your WordPress database is out-of-date, and must be upgraded before you can continue.
    
    The upgrade process may take a while, so please be patient.
    Upgrade WordPress ยป

    …and I noticed that all my categories are missing, each posted is listed as “uncategorized”.

    Any thoughts?? Why would my database be “out-of-date”??

    Thanks!!

    I don’t think the ‘database upgrade’ to 2.3 actually worked.

    This is just a guess, but see if you can increase the amount of memory available to PHP.

    I read on either the wp-hackers or wp-testers email list where a user had to really up the PHP memory to get the upgrade to work. That user had quite a few posts.

    I’ll try rebooting my server and see if that frees up some memory.

    How can I check to see if the database upgrade actually worked?

    Anyone?

    You may try to alter the following two lines in the global php.ini files on your server:

    max_execution_time = 00 — ( the 00 value is an example ) Double the current value
    memory_limit = 00M — Double the current value
    max_input_time = 00 — Double the current value

    It seems that your upgrade scripts times our. This can be caused from the above settings.

    Also you may check the configuration of your web server and set double it’s current value.

    Once the above settings are modified you should restart the web server.

    Well, I fixed the problem, but now I have a new set of problems. I started a new thread concerning them: http://wordpress.org/support/topic/141108?replies=1#post-640683

    Here’s what I did to fix this:

    1. I renamed all my tables.
    2. I went to my blog, it didn’t find any of my tables and thought it was a brand new blog so it setup the default tables.
    3. I ran the upgrade which was “successful”.
    4. I renamed all my tables back to their original names.

    But now I’m having some small problems with categories and post authors missing. I’m guessing this has to do with the fact that my database was never properly upgraded, but at least I can get into my control panel now.

    Thanks to everyone for their help!! ๐Ÿ™‚

    By the way, if anyone wants to contact me personally about this, please e-mail: phil at finlandforthought dot net

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Error: “Your database is out-of-date. Please upgrade.” HELP!!’ is closed to new replies.
Skip to toolbar