Support » Plugin: WordPress + Microsoft Office 365 / Azure AD | LOGIN » ERROR: WPO365 is not configured

  • Hi,

    I have an issue with the configuration of this plugin. I’m entering the correct Directory and Application ID, the redirect URL with a slash on the end, such as the NONCE_SALT Key, but when I’m pressing Save + Test configuration, nothing happens.

    In error/debug log I have this:
    ERROR: WPO365 is not configured -> Redirect URL is missing.
    ERROR: WPO365 is not configured -> Application ID is missing.
    ERROR: WPO365 is not configured -> Tenant ID is missing.

    I keep getting this even my IDs and URL are correctly pasted.

    Can you please help me with this?

    Many thanks!

    • This topic was modified 1 year, 2 months ago by sancukosan.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author wpo365

    (@wpo365)

    If you are absolutely sure that you entered these values on the Single Sign on tab of the wizard (as also documented in this quick installation guide https://youtu.be/fNrwX24p1gU) then there is maybe a small chance that your WordPress hoster is using some server-side caching plugin (or possibly you installed one yourself) and maybe you must purge this cache before saved changes take effect.

    Hi,

    Yes, I’m absolutely sure about the values on the Single Sign page because I was following the video and I have watched it a couple of times.

    Btw, I’m not using any cache plugin. I was using it previously but I deleted it because it wasn’t good enough for my website.

    Plugin Author wpo365

    (@wpo365)

    Hi @sancukosan – Unfortunately, there isn’t much that I can do from where I am. The only other explanation that I can think of would be that your settings are not saved at all. In this case you should notice that the values you previously entered are not saved e.g. when you refresh the page. If this is the case then please check your security settings. The plugin’s wizard uses the WP AJAX API (for authenticated users) to send the settings to the server. Could it be the case that you have blocked this API?

    Hi @wpo365

    I’m using WP Cerber and I have enabled AJAX API request from there too, but I still have the same problem. I will install a new instance from WordPress to test the plugin. If it works, then probably the issue is coming from a conflict with some of my other plugins.

    I will let you know as soon as I will test it.

    Cheers

    Plugin Author wpo365

    (@wpo365)

    @sancukosan Are you using WP Multisite by any chance? Also you can take a more technical approach and have a look at the network traffic. To do so you can start the Developer Tools (press F12) of your browser and then go to the Network tab. When you press “Save configuration” you should see the request to admin-ajax.php. You can check the response (by clicking on the request) and see whether it reports an error. However, if it states “OK” then your problem is not saving the configuration but rather retrieving it. You can also check in your database in the wp_options table and search for the “wpo365_options” entry to see whether your settings are actually saved in the database or not.

    HI @wpo365,

    I was having an issue with the database because previously the IDs weren’t saved in the inputs, but after creating a new fresh instance of WordPress, everything seems to work fine.

    So, thanks for that, but I have one last question.

    in htaccess I have implemented the code below and also I have configured the website with my SSL certificate (which means the page is opened in HTTPS correctly), but I’m still getting the following error:

    ERROR: Please update your htaccess or similar and ensure that users can only access your website via https:// (detected state: http://mywebsite.com/).

    Code:

    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]
    • This reply was modified 1 year, 2 months ago by sancukosan.
    • This reply was modified 1 year, 2 months ago by sancukosan.
    • This reply was modified 1 year, 2 months ago by sancukosan.
    • This reply was modified 1 year, 2 months ago by sancukosan.
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘ERROR: WPO365 is not configured’ is closed to new replies.