Support » Plugin: Fast Velocity Minify » Error: /wp-content/cache/fvm): failed to open dir: No such file or directory

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Raul Peixoto

    (@alignak)

    I don’t quite like Pantheon because of the workflow… but what you are seeing, is (probably) because you updated the FVM plugin on the live site instead of following the dev > test > live.

    Even if you are doing it right, your site may not have permissions to create the directory, so at least, make sure the cache directory exists and that it has writing permissions for the server.

    On Pantheon, you usually always have to go from dev to test and then deploy to live.

    On the latest version, FVM changed the directory where the cache files are located, from the uploads directory to the cache directory (it makes more sense).

    Because you updated FVM on the live version without going through dev and test, FVM nas no permissions to create that missing directory.

    You have to manually create the wp-content/cache directory and chmod it 755 (or perhaps 777) for FVM to be able to create directories and cache files as needed.

    Or you can go to the FVM plugin settings and change the directory to the uploads directory, introducing the path and url as instructed.

    Creating the cache directory and set the correct permissions is probably what you need.
    The cache directory should always exist, since that’s the default location for wordpress to store temporary cache files.

    No I didn’t update the plugin in Live site but in Dev. I did further debug by rollbacking the Version to 2.5.9 and did notice that everything works fine. I even downgraded to 2.5.8 and there also no issue.

    Okay so this makes sense.
    On the latest version, FVM changed the directory where the cache files are located, from the uploads directory to the cache directory.

    However, pantheon.io doesn’t allow to commit the cache directory from dev to test or test to stage, which makes things worse. Anyways let me check and update you, or else will resolve the thread.

    Plugin Author Raul Peixoto

    (@alignak)

    Thanks for the reply.

    It was working before, simply because the wp-content/uploads directory already exists 🙂
    In that case, simply change the cache directory on the plugin settings, back to the wp-content/uploads directory (full path) and it will work as the previous version.

    Maybe you could try to manually create the directory as well, but I would fire a ticket to Pantheon regardless.
    They should not block the wp-content/cache directory… it exists for a purpose and it’s used by many other plugins.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.