[resolved] ERROR: WordPress requires Cookies (8 posts)

  1. MatthewMcCabe
    Posted 7 years ago #

    Whenever I try to log ınto my blog I get the followıng error:

    ERROR: WordPress requires Cookies but your browser does not support them or they are blocked.

    I don't thınk the browser(s) I am usıng are set up to block cookıes.

  2. Jeremy Clark
    Posted 7 years ago #

    Can you confirm the version of wp your using.

  3. Provide a link to the site so that we can see the problem ourselves. No need to give us a login, just the URL.

    Most of the time, the cookie error is a symptom of a deeper underlying problem.

  4. MatthewMcCabe
    Posted 7 years ago #

  5. Your wp-login page is showing a blank line before the doctype. This means that you have a blank line somewhere in the code that you need to remove. It could be in a plugin, it could be in the wp-config file, whatever, but somewhere there is an extra blank line. That blank line is blocking the cookies. Find it, eliminate it.

  6. MatthewMcCabe
    Posted 7 years ago #

    Thanks Otto.

  7. MatthewMcCabe
    Posted 7 years ago #

    I've been rather slow to fix this (I'll blame it on the fact that I'm travelling at the moment) but Otto was absolutely correct. I was too lazy to check get rid of every blank line in my plugin files however and therefore just deleted them :p.

  8. akirtland
    Posted 7 years ago #

    I just updated to 2.3.3 and I'm still have the same cookie error problem. I've tried many things, but none of them have worked. Many suggestions involve deleting blank lines. I see a lot of blank lines in all my files. I'm sure I don't understand what is meant by a "blank line"

    I've tried commenting out the three lines people suggest.

    I've tried using Opera, a different computer, and so on.

    In addition I have no problem logging in during the daytime, usually, but just no luck early morning or late night. The times seem rather standard (10AM to 10PM I can log in without the error), which makes me think it's related to something on my system, or related to my hosting service (fatcow).

    What gives? I'm a bit at the end of my rope.


Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.