Support » Fixing WordPress » ERROR: WordPress 2.9 requires MySQL 4.1.2 or higher

  • I try to install WordPress 2.9 automaticly but I have: ERROR: WordPress 2.9 requires MySQL 4.1.2 or higher What’s that? I can’t see my dashboard so I can’t do nothing anymore. Help!!
    How can I take it back to 2.8.6?

Viewing 15 replies - 1 through 15 (of 18 total)
  • firstly, tell your host that it sucks and that it should update mysql to something that isn’t almost 10 years old.

    next, manually re-uploaded 2.8.6 on your site. (the database shouldn’t have been upgraded because of the same error, so you should be fine.)

    Dealing with the same problem, so about to go back to 2.8.6. But Denis-de-Bernardy, it’s not necessary the host’s issue. I’ve been managing my blog for nearly five years, starting back when MySQL 4.0 was the norm. I never had a problem until using WP Automatic Upgrade last night and was told halfway through the update that I needed 4.1.2+.

    same message, I’m at OVH, my database is MySQL 5.0.51a

    Ok, solved. I’m back to 2.8.6 without any problems. I uploaded again manualy. Strange that I have problems with MySQL. I have no problems with all the other upgrades. 2.9 is the first upgrade I have problems.
    My hosting provider runs MySQL 4.0.24 Standard. So they must upgrade to 4.1.2.??

    I had the same problem. I restored it to 2.8.6 without problem. Does this mean that I really need MySQL 4.1.2 or does it mean that I have to do a manual upgrade ?

    Version 2.9

    Highlights

    * Requires MySQL 4.1.2 or greater (old requirement was 4.0).

    so should i go to mysql 5, to do this i have to delete the database and make another one as it’s on a different server, how long till WP3.0 hits as i’d rather go to an MU install and do it all at once.

    3.0 is penciled in for around March-June time I believe.

    Ask your hosting service to upgrade the MySQL version, because you guy are now stucked on 2.8.6 wp version.

    I had this same problem on 1and1. I ended up creating a new MySQL 5.0 db, exporting my old db, importing to the new one, and then changing my wp-config to point to the new database.

    Here’s the step by step how to do it – What I learned upgrading to WordPress 2.9

    Too bad WP Automatic Upgrade doesn’t check the DB version before taking you 90% through the install…

    I’m having the same issue and having no luck whatsoever with the export/import creation of a new 5.0 database on 1and1. I keep getting either “no mysql query” or “no tables in database” error messages after the import — very frustrating.

    That said, my old WP install still seems to be working fine despite the failed update attempt.

    Okay, I just got it working… given all of the errors I got with exported databases from myphpadmin, I recommend using the WordPress backups.

    I’ve just upgraded manually (because the automatic upgrade fell over) to 2.9.1. However WordPress refuses to do an “upgrade” because it “requires” MySQL version 4.1.2 or higher and my provider is running “only” version 4.0.27!

    I strongly suggest you mention this requirement on the download pages. Then one wouldn’t begin the process until it was provided. But without that essential piece of information I’ve now spent a long time on a manual install only to be worse off than I was before!

    Brilliant product, chaps, but this is a teensy problem.

    How do I put 2.8.6 back, when it’s not available on the download page? The last upgrade was an automatic one so I didn’t get the download.

    Where will I find it or what should I do? I cannot write posts, approve comments or anything. Please help.

    Thanks.

    Richard Treadgold
    http://www.climateconversation.wordshine.co.nz

    @doncampbell.

    Thank you for the upgrade steps. I’m proceeding now. I’m waiting for my installation to be downloaded to my computer, just to be sure (although a bit late).

    I think the database created by WordPress admin has the things removed that you had to remove.

    I hope the WordPress team has gotten the word that there is a problem with this upgrade.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘ERROR: WordPress 2.9 requires MySQL 4.1.2 or higher’ is closed to new replies.