Support » Plugin: The SEO Framework » Error with WPML canonical urls

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Sybre Waaijer

    (@cybr)

    Hi pandafeet,

    I had no idea that using other TLD’s were possible! I assumed that with Option 2 (different domain per language) it was always going to be a sub-domain.

    I’ll make sure to get this straightened out in the near future :). Thanks for reporting this mishap!

    I advice you to disable the Canonical URL from The SEO Framework in the meantime. As a wrong Canonical URL will tell Search Engines to go elsewhere.
    This can be done with the following filter:

    add_filter( 'the_seo_framework_output_canonical', '__return_false' );

    Not having a Canonical URL is OK; although not optimal, it shouldn’t hurt rankings.

    Hello
    Thanks a lot for your help on this issue.
    The filter removed the canonical url fine. However, there is still the incorrect urls on:
    <meta property=”og:url” content=”” />
    <script type=”application/ld+json”>

    Plugin Author Sybre Waaijer

    (@cybr)

    Hi pandafeet,

    Unfortunately, the og:url doesn’t have a specific filter.
    The LD+Json scripts can be turned off through the Schema Settings.

    However, both the og:url and these scripts are used for “information manifestation”. This means that it’s used to enrich or improve the results (Structured Data), when done correctly. They have little to no impact on SERP ranking as of yet.

    I hope to get this resolved as of this weekend :).

    Until then, have a great one!

    Thanks a lot for very fast reply.
    I will wait for your solution.

    Thanks a lot great support!

    Plugin Author Sybre Waaijer

    (@cybr)

    Hi pandafeet,

    The current beta/RT release contains the fix for this :). Feel free to test it out, more info is found here.

    Thanks and have a great day! Cheers :).

    Hello Sybre
    Thanks for your help on this issue.
    It seems the issue is still not completely resolved.

    The canonical url, and those other urls now show like this on secondary languages.

    supposed to be for example
    https://www.domain.se/

    shows:
    https://www.domain.com/www.domain.se/

    Please see this screenshot:
    http://pandafeet.com/canonicalerror.jpg

    Thanks!

    Plugin Author Sybre Waaijer

    (@cybr)

    Hi pandafeet,

    Could you send me a screenshot of your WPML Language URL Format configuration as I’m unable to replicate this issue.

    You can send the info right here at my contact page.

    Thank you so much!

    Plugin Author Sybre Waaijer

    (@cybr)

    This issue has been resolved as of 2.6.5.

    Thank you so much for your cooperation pandafeet! 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Error with WPML canonical urls’ is closed to new replies.