Support » Plugin: WooCommerce » Error with WPML after updating to 3.3.4

  • Resolved christian70

    (@christian70)


    I’m working on a new site locally, with WPML and two languages enabled. After updating Woocommerce plugin from 3.3.3 to 3.3.4 version, this error occurs on my console when browsing on secondary language:
    [local site url]/?wc-ajax=get_refreshed_fragments 404 (Not Found)
    WPML and WPML WooCommerce Multilingual are also installed (all latest versions).
    Any suggestion to fix it? Otherwise I have to go back to previous 3.3.3 version, that worked perfectly.
    Thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Caleb Burks

    (@icaleb)

    Automattic Happiness Engineer

    Probably has to do with this item in the changelog:

    > Fix – Use relative scheme for AJAX endpoint to avoid errors when using a mix of HTTP and HTTPS.

    More info here: https://github.com/woocommerce/woocommerce/issues/19116

    If this only breaks when WPML is enabled, I would reach out to them as well so they can take a look at the changeset.

    Not sure it is due to http/https: I’ve just started working on the project locally, so there’s only http protocol. The 404 error occurs only if WPML is enabled and browsing the site in the secondary language. With the default language everything is fine. So I guess the problem is due to WPML and Woocommerce together. With Woocommerce 3.3.3 no issues at all.

    • This reply was modified 1 year, 1 month ago by  christian70.
    • This reply was modified 1 year, 1 month ago by  christian70.
    Plugin Support Caleb Burks

    (@icaleb)

    Automattic Happiness Engineer

    The change/fix was because of a http/https issue, that doesn’t mean this is the cause on your site.

    This same change also looks to have caused problems in WPML which is the problem here. They must be doing something unusual with the AJAX endpoint.

    gore.m

    (@gorem)

    I have same problem as @christian70.
    @christian70 have you found out how to fix that?

    Thanks you

    christian70

    (@christian70)

    No @gorem, sorry no solution yet. I’m in contact with WPML, but still waiting for support. For now the only way to fix it is using 3.3.3 version that works perfectly in my case.

    gore.m

    (@gorem)

    OK, thanks you

    gore.m

    (@gorem)

    As @christian70 sugested, Ive downgraded to Woocommerce 3.3.3 and I can confirm errors are gone. And I think I can agree with @icaleb it is obviously because of 3.3.4 Woocommerce 3.3.4 update:
    * Fix - Use relative scheme for AJAX endpoint to avoid errors when using a mix of HTTP and HTTPS.

    Unfortunately Woocommerces “Status page” losed here itself sense, it should warn that Woocommerce mutlilingual v4.2.9 is “Not tested with the active version of WooCommerce” or is incompatible with Woocommerce 3.3.4.

    Ankit Gade

    (@ankitgadertcampcom)

    gore.m

    (@gorem)

    Cool, it is working, thanks you .-)

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Error with WPML after updating to 3.3.4’ is closed to new replies.