WordPress.org

Forums

Force Regenerate Thumbnails
[resolved] Error with WordPress 3.5.1 (6 posts)

  1. Ov3rfly
    Member
    Posted 2 years ago #

    With WordPress 3.5.1 there is currently this result:

    Process Information
    
    Total Images: 1
    Successes:: 0
    Failures: 1	
    
        function (){if(a){var t=a.length;(function r(t){v.each(t,function(t,n){var i=v.type(n);i==="function"?(!e.unique||!c.has(n))&&a.push(n):n&&n.length&&i!=="string"&&r(n)})})(arguments),i?o=a.length:n&&(s=t,l(n))}return this}

    Is this a known problem? Did you already work on 3.5.1 compatibility?

    http://wordpress.org/extend/plugins/force-regenerate-thumbnails/

  2. Pedro Elsner
    Member
    Plugin Author

    Posted 2 years ago #

    Yes, did work!
    It was a response of javascript code, that happen in some linux server.
    I don't know the exact reason for this error... =(

    Try set

    chmod 777
    in your thumbnails directory.

    Otherwise, try to use this another plugin:
    http://wordpress.org/extend/plugins/regenerate-thumbnails/

  3. Ov3rfly
    Member
    Posted 2 years ago #

    Thanks for quick answer.

    The described problem appeared only on my Windows development-server.

    Edit: I finally tracked it down, there was a PHP warning of another plugin, because of define('WP_DEBUG', true); in wp-config.php and because of this the POST to /wp-admin/admin-ajax.php got the PHP warning as result which of course is no valid JSON...

    On my production servers with no warnings enabled all works fine.

  4. Pedro Elsner
    Member
    Plugin Author

    Posted 2 years ago #

    I have a blog with this plugin running on Windows + Apache =/

  5. Ov3rfly
    Member
    Posted 2 years ago #

    Tracked down the problem, see also edited post above, here the response of the ajax-call, the regeneration worked, only the display of result-message gets messed up because of malformed JSON (Notices caused by another plugin):

    <br />
    <b>Notice</b>:  some php warning text... in <b>C:\some path\web\wp-includes\functions.php</b> on line <b>2839</b><br />
    <br />
    <b>Notice</b>:  some php warning text... in <b>C:\some path\web\wp-includes\functions.php</b> on line <b>2839</b><br />
    {"success":"<b>Some image name (ID 2085): All thumbnails was successfully regenerated in 2,013 seconds.<\/b>"}
  6. Pedro Elsner
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you Ov3rfly. =)
    I get it!
    I will fix it at next version plugin.

    For now, disconsider this message.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Force Regenerate Thumbnails
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.