WordPress.org

Support

Support » Plugins and Hacks » Sharebar » Error with WordPress 3.5

Error with WordPress 3.5

  • I am getting this error on all posts when I updated to wordpress 3.5

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/content/68/8824068/html/opadventureteamcom/wp-content/plugins/sharebar/sharebar.php on line 112 and defined in /home/content/68/8824068/html/opadventureteamcom/wp-includes/wp-db.php on line 990

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/content/68/8824068/html/opadventureteamcom/wp-content/plugins/sharebar/sharebar.php on line 124 and defined in /home/content/68/8824068/html/opadventureteamcom/wp-includes/wp-db.php on line 990

    http://wordpress.org/extend/plugins/sharebar/

Viewing 15 replies - 1 through 15 (of 39 total)
  • I am also getting this error. I KNEW I shouldn’t have upgraded my wordpress installation yet.

    Any fix for this yet?!? This error is showing up on all my post pages!

    I am also getting this error on all pages including admin. Please help us…

    http://cyrilfb.com

    I have the same error using the Sharebar plugin. Until the developers update their plugins try this in your function.php

    ini_set( ‘display_errors’, false );
    error_reporting( 0 );

    It stops error mesages and once the plugin devs update- just remove the code.

    Worked over at http://www.outdoorphotography.co.nz/

    I have restored my site from backup. I could not leave it with those errors showing.

    sorry, this is the error I was getting. It is different.

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/content/76/8978276/html/wp-content/plugins/digiproveblog/CopyrightProof.php on line 810 and defined in /home/content/76/8978276/html/wp-includes/wp-db.php on line 990

    It cannot be viewed now because I restored from backup.

    http://cyrilfb.com

    Hi All,

    I had the same problem, I have a quick fix, not sure if its the right way but it seems to of worked for me. Edit the following file, sharebar.php

    On Lines 112 and 124, change the following lines of code from this:

    Line 112
    $results =$wpdb->get_results($wpdb->prepare("SELECT * FROM ".$wpdb->prefix."sharebar WHERE enabled=1 ORDER BY position, id ASC")); $str .= "\n";

    to this

    $results =$wpdb->get_results($wpdb->prepare("SELECT * FROM ".$wpdb->prefix."sharebar WHERE enabled=1 ORDER BY position, id ASC", null)); $str .= "\n";

    Line 124

    From this

    ` $results = $wpdb->get_results($wpdb->prepare(“SELECT * FROM “.$wpdb->prefix.”sharebar WHERE enabled=1 ORDER BY position, id ASC”)); $str .= “\n”;
    `

    to this

    $results = $wpdb->get_results($wpdb->prepare("SELECT * FROM ".$wpdb->prefix."sharebar WHERE enabled=1 ORDER BY position, id ASC", null)); $str .= "\n";

    You may or may not need to edit line 124 depending on your position…as I say its a quick fix and its worked for me… hope this helps someone…

    We shouldn’t have to change the code in our themes to get around a bug in a plugin. My “workaround” for now at least was to disable the sharebar. If they can’t fix the sharebar plugin soon enough, there are plenty of other sharebars out there.

    e3mobile…thanks for adding in the null for the additional argument, (worked just fine!) the sharebar author will probably use your code to patch the plugin. =)

    kvnsmooth, feel your pain, but remember wp 3.5 was *just* released and most of these hard working plugin authors don’t even know what the wp devs are adding (and can’t see the probs until they occur) they are nice enough to give us their plugins for free. so, probably best to have juuuuuuust a bit more patience.

    e3mobile, thanks for the quick fix. I encountered the same error and applied your solution. Everything works fine now. I hope the plugin author would release an official update soon.

    Yeah you are right, I’m being a little too hard on them. I should have known better than to immediately upgrade. Lots of plugins that are used a lot were had updates immediately. So I assumed developers have had early access to 3.5. Doesn’t mean they actively were working with it though. Looks like I have to stick to either paid plugins or ones that are under active development.

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/resonate/public_html/wp-content/plugins/sharebar/sharebar.php on line 112 and defined in /home/resonate/public_html/wp-includes/wp-db.php on line 990

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/resonate/public_html/wp-content/plugins/sharebar/sharebar.php on line 124 and defined in /home/resonate/public_html/wp-includes/wp-db.php on line 990
    Neither changing the functions.php or editing the sharebar.php lines 112 or 124 have worked. 🙁 Does anybody else have any suggestions?

    e3mobile, thank you for the fix. I applied it on my blog (Pexiweb.be) and it works fine.

    Thanks so much for this fix. Didn’t break till I switched to a shiny new theme and I was gutted when I saw the error but works fine now 🙂

    THANKS A LOT e3mobile!! It works for me.

    Nice work. Worked lovely.

Viewing 15 replies - 1 through 15 (of 39 total)
  • The topic ‘Error with WordPress 3.5’ is closed to new replies.
Skip to toolbar