• Resolved lamefe

    (@lamefe)


    I David, nice plugin unfortunately I just got an error message while activating it on a new site:
    WordPress-Version 6.1
    Aktives Theme: Twenty Twenty-Two Child (Version 0.2)
    Aktuelles Plugin: Simple Location (Version 4.5.0)
    PHP-Version 8.0.24

    Fehler-Details
    ==============
    Ein Fehler vom Typ E_ERROR wurde in der Zeile 113 der Datei /wp-content/plugins/simple-location/includes/class-weather-provider-station.php verursacht. Fehlermeldung: Uncaught TypeError: array_key_exists(): Argument #2 ($array) must be of type array, string given in /wp-content/plugins/simple-location/includes/class-weather-provider-station.php:113
    Stack trace:
    #0 /wp-content/plugins/simple-location/includes/class-weather-provider-station.php(136): Weather_Provider_Station::key('', 'id')
    #1 /wp-content/plugins/simple-location/includes/class-weather-provider-station.php(93): Weather_Provider_Station::station_inputs('0')
    #2 /wp-admin/includes/template.php(1785): Weather_Provider_Station::stations_callback(Array)
    #3 /wp-admin/includes/template.php(1739): do_settings_fields('sloc_stations', 'sloc_stations')
    #4 /wp-content/plugins/simple-location/includes/class-loc-config.php(410): do_settings_sections('sloc_stations')
    #5 /wp-includes/class-wp-hook.php(308): Loc_Config::simloc_options('')
    #6 /wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters('', Array)
    #7 /wp-includes/plugin.php(517): WP_Hook->do_action(Array)
    #8 /wp-admin/admin.php(259): do_action('settings_page_s...')
    #9 /wp-admin/options-general.php(10): require_once('/homepages/22/d...')
    #10 {main}
    thrown
    • This topic was modified 1 year, 7 months ago by lamefe.
Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author David Shanske

    (@dshanske)

    I am working on version 5.0 of the plugin now. I’ve made an adjustment for this issue, but it might be a few days before release as it is a rather large release I’ve been working on for a bit.

    Thread Starter lamefe

    (@lamefe)

    Thanks for your quick reply. Great! I’m looking forward to 5.0

    Thread Starter lamefe

    (@lamefe)

    not to bother you, but it seems to be a problem caused at the installation. It works fine with Wp 6.1 and T17 at another installation. Is there any possibility to fully delete the plugin?

    Plugin Author David Shanske

    (@dshanske)

    What do you mean delete? You can always remove a plugin. The issue is that configuration is not initialized on load. Ironically, the station feature is one that doesn’t get used much. So I could tell you how to edit the file to disable it until the update.

    Thread Starter lamefe

    (@lamefe)

    I ordinary deleted/installed it several times, I just thought there might be data written somewhere deeper in the databank I

    Yes, to disable it was just perfect!

    Plugin Author David Shanske

    (@dshanske)

    Are you willing to install from the dev version? I can get you a zip. Is that easier?

    Thread Starter lamefe

    (@lamefe)

    Perfect! Thank you so much!

    • This reply was modified 1 year, 7 months ago by lamefe.
    Plugin Author David Shanske

    (@dshanske)

    I’ll push the change to the GitHub repo tonight and can refer you to the download.. if you don’t mind beta testing 5.0.

    Thread Starter lamefe

    (@lamefe)

    Great! Thank you so much. I don’t mind, my project is beta too 🙂
    I just have a pitch ahead, so I’m happy to have it running somehow.

    Plugin Author David Shanske

    (@dshanske)

    Try downloading the zip from https://github.com/dshanske/simple-location and see if that works.

    Plugin Author David Shanske

    (@dshanske)

    New version released.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Error with Stations’ is closed to new replies.