Support » Plugin: Advanced Editor Tools (previously TinyMCE Advanced) » Error with saving page content – TMCE 4.7.11 / WP 4.9.6 with Avada Theme

  • Hi,

    I’m using TinyMCE Advanced 4.7.11 in WP-4.9.6 with the Avada theme (incl. the “Fusion Builder”).

    With the activated plugin it’s not possible to save edited page content anymore. Also reinstalling the plugin did not help. Only deactivation of the TinyMCE Advanced 4.7.11 plugin helps.

    To edit the content of my pages I have to deactivate the plugin until the next update comes. šŸ™

    Any help would be greatly appreciated.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello,

    I have exactly the same problem. Iā€™m using TinyMCE Advanced 4.7.11 in WP-4.9.6 with the Avada theme.

    I could’nt save my page content !!!

    I need help !
    Thank you very much.

    Charles (France)

    • This reply was modified 3 years, 1 month ago by charles59169.
    Thread Starter knubew

    (@knubew)

    In the latest WordPress update (4.9.6) the TinyMCE Version was updated to version 4.7.11 but unfortunately “TinyMCE Advanced 4.7.11” does not work.

    Please update the “TinyMCE Advanced 4.7.11” plugin.

    Thank you in advance.
    Knut (Germany)

    Plugin Author Andrew Ozz

    (@azaozz)

    Ive seen few tickets before about incompatibilities between TinyMCE Advanced and the Avada theme, or perhaps a component it uses. That may also be a general incompatibility with the theme and the updated editor in WordPress. See:
    https://wordpress.org/support/topic/tinymce-advanced-grays-out-screen-and-freezes-wp/
    https://wordpress.org/support/topic/tinymce-4-6-3-not-compatible-with-avada-5-1-6/

    @knubew @charles59169 could you look in the browser tools and paste here the errors you see? Most importantly the first error.

    • This reply was modified 3 years, 1 month ago by Andrew Ozz.
    Thread Starter knubew

    (@knubew)

    Hi,

    here is the fist error meassage in the list:

    TypeError: n is undefined[Weitere Informationen] theme.min.js:1:101962
    	qi/</</o< https://www.xxx.com/wp-includes/js/tinymce/themes/modern/theme.min.js:1:101962
    	At https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:30955
    	qi/</< https://www.xxx.com/wp-includes/js/tinymce/themes/modern/theme.min.js:1:101941
    	zm/c.fire https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:182881
    	fire https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:183391
    	mC https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:309937
    	pC/< https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:313299
    	loadAll/< https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:85100
    	Kr/</< https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:58117
    

    Here is the second error message in the list:

    TypeError: n is undefined[Weitere Informationen] theme.min.js:1:101962
    	qi/</</o< https://www.xxx.com/wp-includes/js/tinymce/themes/modern/theme.min.js:1:101962
    	At https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:30955
    	qi/</< https://www.xxx.com/wp-includes/js/tinymce/themes/modern/theme.min.js:1:101941
    	zm/c.fire https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:182881
    	fire https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:183391
    	Gp/this.nodeChanged https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:202889
    	nodeChanged https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:329595
    	oh/< https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:223115
    	zm/c.fire https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:182881
    	fire https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:183391
    	add https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:223782
    	a https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:221752
    	zm/c.fire https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:182881
    	fire https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:183391
    	save https://www.xxx.com/wp-includes/js/tinymce/tinymce.min.js:2:331878
    	c/</< https://www.xxx.com/wp-includes/js/autosave.min.js:1:5462
    
    Thread Starter knubew

    (@knubew)

    I’ve posted the errors, but got the message “This post has been held for moderation by our automated system and will be manually reviewed by a moderator.”

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    The spam filters thought your post was interesting. It’s now posted.

    Plugin Author Andrew Ozz

    (@azaozz)

    @knubew thanks for pasting the errors. As far as I see this is related to the “Font Family” drop-down in Firefox. It was fixed in TinyMCE few days ago: https://github.com/tinymce/tinymce/commit/f2244bfef13b815a64f392b0f48c9f7f8ed77311#diff-7c5752f70419f7159533453be95425dd

    TinyMCE will have to be updated in core to fix it, https://core.trac.wordpress.org/ticket/44134. For now perhaps try to remove the “Font Family” drop down from your TinyMCE Advanced configuration.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Error with saving page content – TMCE 4.7.11 / WP 4.9.6 with Avada Theme’ is closed to new replies.