• Resolved eprinsa

    (@eprinsa)


    Hello,
    We are having issues with the object cache when saving content with the Divi theme. We are seeing messages like the following in our logs: RedisException: socket error on read socket in /var/www/vhosts/…/httpdocs/wp-content/object-cache.php Any help would be appreciated as we have tried various configuration options without resolving the error. Thank you. P.S.: We have proceeded to deactivate the plugin until we can resolve the problem, but I add the information here for possible diagnosis Status: No activado
    Client:
    Drop-in: Not installed
    Disabled: No
    PhpRedis: 6.0.2
    Relay: Not loaded
    Predis: 2.1.2
    Credis: Not loaded
    PHP Version: 8.1.27
    Plugin Version: 2.5.0
    Redis Version: Unknown
    Multisite: No
    Metrics: Disabled
    Metrics recorded: 0
    Filesystem: Writable
    WP_CACHE_KEY_SALT: "20b16ed32b55c7112a646b40473aa6fd"
    WP_REDIS_PLUGIN_PATH: "/var/www/vhosts/…/httpdocs/wp-content/plugins/redis-cache"
    Drop-ins: [
    "maintenance.php v by "
    ]
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    That’s a timeout. It can happen. Can you post your diagnostics?

    Thread Starter eprinsa

    (@eprinsa)

    Hello again,
    I add the diagnosis of one of the websites where we are having the problem.
    From what we have observed, the error occurs instantly when trying to save data with the Divi content editor, and for now to solve it we have to disable the redis object cache.

    Diagnosis:

    Status: Conectado
    Client: PhpRedis (v6.0.2)
    Drop-in: Valid
    Disabled: No
    Ping: 1
    Errors: []
    PhpRedis: 6.0.2
    Relay: Not loaded
    Predis: 2.1.2
    Credis: Not loaded
    PHP Version: 8.1.27
    Plugin Version: 2.5.0
    Redis Version: 6.0.16
    Multisite: No
    Metrics: Enabled
    Metrics recorded: 15694
    Filesystem: Writable
    Global Prefix: "S4PbK_"
    Blog Prefix: "S4PbK_"
    WP_REDIS_PREFIX: "a1735b82aa668050c87f4b8f95396e82"
    WP_CACHE_KEY_SALT: "a1735b82aa668050c87f4b8f95396e82"
    WP_REDIS_PLUGIN_PATH: "/var/www/vhosts/priegodecordoba.es/httpdocs/wp-content/plugins/redis-cache"
    Global Groups: [
    "blog-details",
    "blog-id-cache",
    "blog-lookup",
    "global-posts",
    "networks",
    "rss",
    "sites",
    "site-details",
    "site-lookup",
    "site-options",
    "site-transient",
    "users",
    "useremail",
    "userlogins",
    "usermeta",
    "user_meta",
    "userslugs",
    "redis-cache",
    "blog_meta",
    "network-queries",
    "site-queries",
    "user-queries"
    ]
    Ignored Groups: [
    "counts",
    "plugins",
    "theme_json",
    "wordfence",
    "wordfence-ls",
    "themes"
    ]
    Unflushable Groups: []
    Groups Types: {
    "blog-details": "global",
    "blog-id-cache": "global",
    "blog-lookup": "global",
    "global-posts": "global",
    "networks": "global",
    "rss": "global",
    "sites": "global",
    "site-details": "global",
    "site-lookup": "global",
    "site-options": "global",
    "site-transient": "global",
    "users": "global",
    "useremail": "global",
    "userlogins": "global",
    "usermeta": "global",
    "user_meta": "global",
    "userslugs": "global",
    "redis-cache": "global",
    "blog_meta": "global",
    "network-queries": "global",
    "site-queries": "global",
    "user-queries": "global",
    "counts": "ignored",
    "plugins": "ignored",
    "theme_json": "ignored",
    "wordfence": "ignored",
    "wordfence-ls": "ignored",
    "themes": "ignored"
    }
    Drop-ins: [
    "maintenance.php v by ",
    "Redis Object Cache Drop-In v2.5.0 by Till Krüss"
    ]

    Regards

    Plugin Author Till Krüss

    (@tillkruess)

    Try setting WP_REDIS_TIMEOUT and WP_REDIS_READ_TIMEOUT from 1 to 3 to see if that resolves it.

    Thread Starter eprinsa

    (@eprinsa)

    Hello again,
    We are going to try it on one of the websites where we are having the problem. I will report the results here.
    Regards

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.