Support » Plugin: WP-PhotoNav » Error with PhotoNav plugin resulting in no image

  • hytel

    (@hytel)


    I’ve been using photonav for years on my website without issue. Lately I noticed that all photonav screens are now black. I turned on the developer java console and saw the following error:

    Uncaught TypeError: undefined is not a function

    It’s complaining about this resulting wordpress line:

    <script type=”text/javascript”>jQuery(document).ready(function(){jQuery(“#f020d0738e00764b”).photoNav({id:”f020d0738e00764b”,mode:”move”,popup:”none”,animate:”none”,position:”center”,label:”none”});});</script>

    Any ideas?

    https://wordpress.org/plugins/wp-photonav/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Thread Starter hytel

    (@hytel)

    From a bit of reading on the web. This might be happening because the WordPress jQuery mechanism isn’t being used in PhotoNav’s case so it’s in there twice. Apparently WordPress requires plugins to pass jQuery requests through it so it can resolve multiple jQuery calls.

    Plugin Author Fabian Stanke

    (@fmos)

    Thanks for the report.

    PhotoNav does use WordPress’s jQuery mechanism, i.e. it does not bring any other/second copy of jQuery as you can easily verify by looking at the in the plugin directory.

    Do you have a link to an exemplary page where the error happens? Without looking at the error myself I’m afraid I won’t have any chance of fixing it.

    Regards,

    Thread Starter hytel

    (@hytel)

    All my photonav pages seem to be not working in Chrome, e.g. http://analyze3d.com/Site/coral-reef-in-eilat/

    Plugin Author Fabian Stanke

    (@fmos)

    I’ve just had a quick look, but it’s really hard to debug on your website, because jQuery seems to be wrapped up somehow by Modernizr, which – in addition – is minified.
    I did set a breakpoint in the PhotoNav initializer, but the debugger doesn’t even get there, so I’m pretty sure it’s not a problem with PhotoNav.
    Did you try to rule out other problems, e.g. by switching off other plugins?

    Thread Starter hytel

    (@hytel)

    The theme kingsize (one of the more popular themes around) apparently uses modernizr which I saw in the includes on the pages. I tried deactivating a few of the plugins that were relevant to “pages” but it didn’t make any difference. Could be the theme itself, but I’m no expert in Javascript – so I may be stuck. Perhaps I’ll run this by the theme creator. Thanks for taking a look at this.

    artjom

    (@artjom)

    @hytel, you have 2 different versions of jQuery being pulled into your site.
    In my experience, having more than one jQuery version is guaranteed to break things.

    In your header, you’re including this one:

    <script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.7/jquery.min.js?ver=4.0.1'></script>

    But typing “jQuery().jquery” returns version “1.8.1”, so something is pulling in another version.

    After digging a bit, it’s this line:

    <script src="http://analyze3d.com/Site/wp-content/themes/kingsize/js/foundation.min.js"></script>

    Which is Modernizer, but you’re including it again further down, thuis time without jQuery:

    <script src="http://analyze3d.com/Site/wp-content/themes/kingsize/js/modernizr.foundation.js"></script>

    You’ll somehow need to get rid of the double jQuery include. See if you can get rid of the foundation.min.js include without breaking anything.

    If that doesn’t work, get the first jQuery include (from googleapis.com) to download jQuery 1.8.1 (for compatibility with your existing plugins) and get rid of the jQuery include in the foundation.min.js (you’ll recognize it in the file)

    Good luck!

    Thread Starter hytel

    (@hytel)

    I have submitted your observations to the theme author. Let’s see what he says. Thanks!

    Hi, I have a similar problem, if I use Twenty Thirteen template the plugin is working correctly, if I use another template (that I bought) It don’t work animore.

    If I use firebugs, it shows me a message who say “photonav is not a function” in console->errors.
    If you wanna test it, here the address: napolipietrasantabnb.it/prova-immagine-zoom/

    Can you suggest me something to do or check?
    My WP version is 4.1.

    Thanks a lot

    P.S. Sorry for my English

    Plugin Author Fabian Stanke

    (@fmos)

    Thank you for taking the time to report your problem.

    Unfortunately, when I visit your site, my error console reports the following errors:

    [Error] Failed to load resource: the server responded with a status of 503 (Service Unavailable) (prova-immagine-zoom, line 0)
    [Error] Failed to load resource: the server responded with a status of 503 (Service Unavailable) (Napoli2_HDR.jpg, line 0)

    Also, the page seems to be a maintenance page and there doesn’t seem to be a photonav element on that page.

    Cheers

    I’m sorry, I forgot to deactivate maintenance plugin. Can you try again?

    Thread Starter hytel

    (@hytel)

    Yup. This is the same error as on my site. The KingSize theme authors punted on this one and said they made no claim that any other plugin would specifically work with their theme. I’m hoping there is just a simple trick to avoid the jQuery conflict.

    So I need to ask to themes authors to fix this issue??

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Error with PhotoNav plugin resulting in no image’ is closed to new replies.