Support » Fixing WordPress » Error with new fantastico based instalation on AN hosting

  • Hi, I’m new to wordpress, but have just installed it on an AN Hosting account via ‘fantastico’. It seems mostly normal, but it has some serious problems which I think are all connected. The major symptom is that I cannot create new categories via the web interface. I also cannot delete comments with the delete command from the section that lists all recent comments, though I can delete them from the actual blog post. Finally, my index.php file was locked and I had no .htaccess file. When I tried to change the permalink structure in the options, it said that it didn’t have access to the .htaccess file.

    My guess is that the problem is something to do with permissions, but I am not sure. I tried creating a .htaccess file and changing the permissions on the index.php file, and this fixed those problems, but the others remained. Despite trying to change all permissions to very permissive options, I haven’t been able to add categories at all. When I type in the details and click the ‘add’ button, the form resets but nothing else happens.

    Does anyone know what is going on and how to fix it? If you are hosted with AN Hosting, have you had similar problems, or has it just worked? I know my way around ftp and can change file permissions if need be, but I’m no expert.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I know my way around ftp

    Re-upload all files in wp-admin and wp-content folder.

    I had never actually uploaded them in the first place — I had used the control panel to do it for me using fantastico (some suite of mysql things).

    That said, I gave it a go and downloaded the package, deleted the server versions of the folders you mentioned and replaced them with my freshly unzipped versions. Sadly, there was no change. I still can’t add categories and still can’t delete comments via the comments section of the wp-admin (it looks like it is deleting them, but when I reload it I see that they are still really there).

    Any other ideas?

    I am on the install4free team and have found Bluehost to be very good. However, I’m not a huge fan of fantastico.
    Why not submit a request to install4free telling us/them Fantastico may have botched the install.

    Thanks for the offer (which really does seem very generous — I’m impressed!). However, I realized that AN Hosting has enough manual control to let you do a manual installation and I gave it a shot. Happily it seems to work perfectly, and I haven’t even had to touch any permissions yet. It looks like Fantastico probably was at fault.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Error with new fantastico based instalation on AN hosting’ is closed to new replies.