Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Error with latest JetPack

  • Resolved AccountKiller

    (@bazajaytee)


    Since updating JetPack I have noticed some unusual behaviour.

    First, in posts where I have embedded Tweets from Twitter, they don’t show all of the content. Like you can see on this post http://www.insidegamer.net/2017/10/24/playerunknowns-battlegrounds-disc-release-xbox-one/
    Second, when I go to Posts pages, the Twitter and Google+ feeds don’t load. The widgets are the JetPack ones. The same widgets are used on the main page and they work but the exact settings don’t work on Posts pages.

    Looking at debug I see this:

    WebSocket connection to ‘wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data’ failed: Error during WebSocket handshake: Unexpected response code: 403

    This only started after the most recent JetPack update.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Everything worked the first time I loaded the page:
    https://i0.wp.com/i.jeremy.hu/screenshot-2017-10-27-at-18-48-11.png
    https://i0.wp.com/i.jeremy.hu/screenshot-2017-10-27-at-18-49-32.png

    But then when I refreshed, I could reproduce the issue.

    Looking at the browser console, I see an error related to Disqus, so I think the problem is linked to all third party resources on the page, including WordPress.com notifications as the error message you posted above indicates. I don’t see that specific error because I am not logged into your site so I don’t see any notification window.

    Interestingly, access to your site’s XML-RPC is also blocked:
    https://i0.wp.com/i.jeremy.hu/screenshot-2017-10-27-at-18-53-54.png

    Since Jetpack relies on that file to communicate with WordPress.com, you will experience issues with most Jetpack features, like Subscriptions.

    That error message makes me wonder if there could be a security plugin on your site that blocks all those things at once. Do you use such a plugin? If so, could you try to deactivate it and see if it helps?

    Thread Starter AccountKiller

    (@bazajaytee)

    I do use All In One WP Security and have blocked XMLRPC.php from external access but do allow JetPack pingback in the settings.

    If you use Jetpack or WP iOS or other apps which need WP XML-RPC functionality then check this.

    I disabled the WP Security and same issue persists. I tried clearing Cloudflare and local cache too just in case, no luck.

    Is there an IP range I should/can look at which WordPress/JetPack uses to make sure it isn’t being blocked?

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    I do use All In One WP Security and have blocked XMLRPC.php from external access but do allow JetPack pingback in the settings.

    That setting does not appear to work right now, I’m afraid. I get a 403 whenever I try to make requests to that file from WordPress.com.

    Is there an IP range I should/can look at which WordPress/JetPack uses to make sure it isn’t being blocked?

    Yes, you can find our IP ranges here:
    https://jetpack.com/support/hosting-faq/#jetpack-whitelist

    I disabled the WP Security and same issue persists. I tried clearing Cloudflare and local cache too just in case, no luck.

    Could you try to deactivate your caching / concatenating plugin altogether, and see if it helps?

    Thread Starter AccountKiller

    (@bazajaytee)

    No luck 🙁

    Even tried disabling other plugins but same result. Obviously disabling Jetpack stops the widegts altogether. I even tried rolling back the theme and trying a new theme. Same result.

    What I am seeing is if I embed a Tweet the widgets don’t seem to show and posts without embedded Tweets seem to work.

    Works with no embed – http://www.insidegamer.net/2017/10/27/gamemaker-studio-2-adds-universal-windows-platform-support/

    Doesn’t work with an embedded Tweet in the post – http://www.insidegamer.net/2017/10/27/xbox-one-game-gifting/

    Also, I removed the block on the file WordPress uses and whitelisted the IP’s just incase.

    • This reply was modified 3 years, 5 months ago by AccountKiller. Reason: Added extra info
    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    What I am seeing is if I embed a Tweet the widgets don’t seem to show and posts without embedded Tweets seem to work.

    Works with no embed – http://www.insidegamer.net/2017/10/27/gamemaker-studio-2-adds-universal-windows-platform-support/

    Doesn’t work with an embedded Tweet in the post – http://www.insidegamer.net/2017/10/27/xbox-one-game-gifting/

    This seems to be a bit random; I can see the widgets on both pages right now. But when I refresh, the problem appears.

    Could you let me know how you embedded the tweets? Did you just paste the Tweet URL on its own separate line? If so, you could deactivate the Shortcode Embeds module here to make sure Jetpack doesn’t interact with that embed:
    http://www.insidegamer.net/wp-admin/admin.php?page=jetpack_modules

    Then, go to this page and create your own Twitter widget:
    https://twitter.com/settings/widgets?lang=en

    Copy the code that gets generated for you, and paste it into a new Text widget (in the Text view) under Appearance > Widgets. If you replace the existing Twitter Widget from Jetpack by this one and then try loading the page a few times, do you still experience issues? If so, we’ll know the problem does not come from Jetpack. If the problem disappears, that will confirm that the problem comes from Jetpack.

    Let me know how it goes.

    Thread Starter AccountKiller

    (@bazajaytee)

    I embed the code direct from Twitter into posts and paste it into the text editor. I only realised WordPress could convert links to posts yesterday when I started looking into this issue 🙂

    So I use something like this (I add the center tags to make it show in the middle.

    <center><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">happy halloweeeeen <a href="https://t.co/opHmD3erwn">pic.twitter.com/opHmD3erwn</a></p>&mdash; OutsideXbox (@OutsideXbox) <a href="https://twitter.com/OutsideXbox/status/923926211713290247?ref_src=twsrc%5Etfw">October 27, 2017</a></blockquote>
    <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
    </cetner>

    The widget is the Jetpack widget with the ID but I tried what you mentioned and it didn’t show up with the Twitter code either. Again, shows up if there is no Tweet in the post but goes away if there is.

    • This reply was modified 3 years, 5 months ago by AccountKiller. Reason: Updated Tweet code list
    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    I tried what you mentioned and it didn’t show up with the Twitter code either

    Thanks for giving it a try. That means the issue is not linked to Jetpack itself.

    I embed the code direct from Twitter into posts and paste it into the text editor. I only realised WordPress could convert links to posts yesterday when I started looking into this issue 🙂

    What happens if you use a simple link instead of pasting that code? Do you experience similar issues?

    Thread Starter AccountKiller

    (@bazajaytee)

    So this seems to have cleared up somehow.

    I did disable RocketLoader in Cloudflare so not sure if it was that or not as that setting was enabled for months previously.

    Still, something changed and it all works again now. Thanks for the support Jeremy but it looks like you were right, it wasn’t Jetpack, at least not the latest version but not sure about the WordPress backend 🙂

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Glad to hear you’re all set, although we’re not sure what happened. 🙂

    If it starts happening again, let me know!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Error with latest JetPack’ is closed to new replies.