• Resolved Mohamed Adel

    (@madel28)


    I have got the below error and It was not found before. and the image I upload it less than 2500px and still seeing this message:

    Post-processing of the image failed. If this is a photo or a large image, please scale it down to 2500 pixels and upload it again.

    I add this
    add_filter( ‘big_image_size_threshold’, ‘__return_false’ );
    to functions.php and installed Disable “BIG image” Threshold

    nothing fix the problem, What should I do?

Viewing 15 replies - 61 through 75 (of 99 total)
  • Solved for me:
    1.Updated memory_limit in PHP Options
    2.unchecked imagick in PHP Extensions.

    Hi there,
    I don’t know if it’s the case, but I’ll try to help.
    I have a WordPress site under a kubernetes cluster and the site give me the same error as you, this is due to a configuration in the proxy.
    You can view the thread that helps me here: https://stackoverflow.com/questions/64104705/increase-max-file-upload-size-in-k8s-cluster-deployed-with-azure-project-in-asp#:~:text=However%2C%20when%20I%20deploy%20using,to%20around%201MB%20in%20size.

    So If you have the site under a Proxy you should first allow great files in the proxy and then in your site.
    Hope this answer helps anyone.
    Best 🙂

    The issue is an apostrophe in the file title!!!

    Just refreshing the page and retrying worked for me today.

    alan

    (@urbanmaniac)

    Whenever i upload any pic to the wordpress site, my site just stops working and i need to restart my instance again.

    I use bitnami wordpress and Aws. Can anyone help to resolve this issue?

    Hi, i am totally a beginner and getting the following error:

    Post-processing of the image failed. If this is a photo or a large image, please scale it down to 2500 pixels and upload it again.

    Due to which some of the images have the url with suffix “scaled” and some not which makes it very difficult to bulk upload the images

    Please suggest a solution without the coding

    Ok… I just experienced this and I was pulling my hair trying to solve this.

    For me the issue was that the .htaccess file was non existent in the root folder. The easiest way I found to solve this was to go to settings => permalinks. Choose a structure and save your permalinks.

    This resolved the issue for me… hopefully it helps someone else.

    Small update;

    I have a site hosted at WPMU DEV hosting (wpmudev.com) the issue is mainly an apostrophe in the file name, it can be an image, video, pdf etc… (any file)

    If you look at https://developer.wordpress.org/reference/functions/sanitize_file_name/you’ll see that WP itself actually treats em as a special character and removes them from the filenames in the function.

    Means that WordPress does accept those files, which is good, however, this can be a treat to the server as well, hackers uses apostrophes to inject code as well, therefore, some hosting that uses a strong firewall, it will Never allow uploading files with apostrophe .

    So, in case you have this issue, you would need to check your WAF as well and see if it is blocking it.

    Hope this helps!

    Cheers
    Youssef

    David11223344

    (@david11223344)

    Very overkill answers and work that had a very simple solution on my end. It was so simple that I’m baffled that I didn’t see one tech mention it.

    What solved this issue for me was not all of this jumping through hoops of ftp or php or workarounds. It was easier than that and so simple. I switched my browser to Google Chrome and tried again.

    Techs, we love you guys, but seriously, sometimes you just make mountains out of molehills and overcomplicate the solution by creating more work on your clientele than is needed. It used to be a tech would ask, “did you try turning it off and then back on again?” Now they ask you to crack open your tablet, go into your electronic device repair lab and break out your lasers so you can check the fourth connection from the left beneath the third processor that requires a special key that you can only download by getting quadruple authentication login from a server that snail mails your new password to you and requires the post office to get your signature, blood sample and your baby foot prints before they’ll deliver it.

    Seriously, switching the browser to Google Chrome, that’s all it took.

    Hi, I am facing the same error although I can’t find a solution in any of the comments you people posted…

    The weird thing is that I get the errors only for the users with roles under Administrator. Authors, editors, etc can’t upload media, where administrators can without any limitation.

    Checked the User Roles through plugins to make sure that there isn’t permission side.

    Nothing works… Any suggestions are welcome.

    Thanks!

    Hello, in my case I fixed it by pausing Cloudflare

    I was having this same issue (same error after image upload stuck at 100%) after moving to 5.7 from 5.3 on a multisite installation.

    There is a known bug in a multisite since 5.6 (not expected to be fixed until 5.9).

    Full defect article:
    #52241 (Infinite loop in clean_dirsize_cache()) – WordPress Trac

    You have to make this one-line change in /wp-includes/functions.php
    Fixed_infinite_loop_on_Windows_systems_.patch on Ticket #52241

    So, if you’ve read this far through the comments you’ve probably worked that out the error message is vague.

    I solved it by checking the log files. That could be for wordpress, but for me (ubuntu, nginx) I found the cause straight away in the nginx error log at /var/log/nginx/error.log

    2021/06/30 15:40:11 [error] 702#702: *2169 client intended to send too large body: 1257288 bytes, client: 1.2.3.4, server: myserver.co.uk, request: “POST /wp-admin/async-upload.php HTTP/1.1”, host: “myserver.co.uk”, referrer: “https://myserver.co.uk/wp-admin/upload.php”

    nginx restricts the maximum size of file that can be uploaded so the solution for me was to add a line to my virtual server file (or it could have gone in nginx.conf but that affects every site on my server)

    server {
    ...
            #increased for uploading images to wordpress
            client_max_body_size 10M;
    ...
    }

    Set the client_max_body_size to a value appropriate for what you expect to upload. 10M = 10 Megabyte and plenty for what I’m uploading. Don’t make it larger than you need and bad people could try and break your site by uploading very large files in a denial of service type attack.
    NB: Other comments here said the upload worked for them when their source was another server, this would bypass the upload stage so I suspect they have the same issue as me.

    nginx -t (to test I didnt mess up the config), then restart nginx, try the upload again and it worked fine.

    Still not working for you?
    After this, the next place to look is PHP error logs. Maybe my file was larger than what PHP allowed and that can be increased.
    After this, the next place to look is the graphics program that’s being called to manipulate the image. For me I’d guess that’s PHP calling imagemagick and I’d be hoping the errors arrive in PHPs error log but maybe imagemagick would write it’s own error log. I read here lots of people are using GD for image manipulation, that may also have it’s own error log. Things that might be happening: The image needs too much memory to process, the image is in a format that can’t be processed (maybe allowed by wordpress/php but not allowed to be manipulated by the image software default).

    *If I had the skill and time, I’d look to contribute code to generate a more useful error messages for this, alas I don’t so hopefully someone find this answer useful.

    I had the same issue with my SiteGround hosting and it was resolved by clearing the cache as per below:

    1) From their interface – https://www.siteground.com/kb/clear-site-cache/
    2) By deleting the “cache” folder under wp-content

    Hope this helps.

    I had this fixed using the following and then after some updates this morning it stopped. Not sure what happened… guess I am headed down the rabbit hole.

    
    function use_gd_editor($array) {
      return array( 'WP_Image_Editor_GD', );
    }
    add_filter( 'wp_image_editors', 'use_gd_editor' );
    
Viewing 15 replies - 61 through 75 (of 99 total)
  • The topic ‘Error with image uploading’ is closed to new replies.