Support » Fixing WordPress » Error with image uploading

  • Resolved Mohamed Adel

    (@madel28)


    I have got the below error and It was not found before. and the image I upload it less than 2500px and still seeing this message:

    Post-processing of the image failed. If this is a photo or a large image, please scale it down to 2500 pixels and upload it again.

    I add this
    add_filter( ‘big_image_size_threshold’, ‘__return_false’ );
    to functions.php and installed Disable “BIG image” Threshold

    nothing fix the problem, What should I do?

Viewing 15 replies - 31 through 45 (of 81 total)
  • SweetPweb

    (@sweetpweb)

    I just had this issue (“Post Processing of the image failed…”) with a fresh WP install and tried updating PHP, memory, etc.

    Finally found it and its a conflict with gd and imagick extensions in php. Ultimately the fix was to disable imagick for image processing. If you have access to your PHP Extensions, make sure to enable GD and disable Imagick. Worked for me.

    thealihamza

    (@thealihamza)

    facing same issue on my website http://www.winproactivator.com

    betredbird

    (@betredbird)

    I am also having this problem. I’m running the latest version of WP (it was added to the site yesterday). Please assist.

    All of my plugins are currently deactivated.

    • This reply was modified 1 year ago by betredbird.
    • This reply was modified 1 year ago by betredbird.
    MFA Bowl

    (@mfabowl)

    I had the same issue and when my IP address changed it wasn’t added to the whitelist of our FIREWALL system. Since I’ve done that, refreshed the page I was able to upload again. It seems that is some kind of IP allowance. Happy to help.

    Kind regards
    Stf – IT Admin

    i was got same issue. image not upload image size 133KB and scale less than <2500px
    however my MAX_UPLOAD size is 512MB supported how can I resolve? please any one help me

    Post-processing of the image failed. If this is a photo or a large image, please scale it down to 2500 pixels and upload it again.

    @joshben
    ‘Add From Server’ plugin really works for me to upload files to server.

    Add this to .htaccess file.
    It’s really worked for me. Thanks God.

    BEGIN a hack to fix upload errors
    SecFilterEngine Off
    SecFilterScanPOST Off
    END a hack

    fallback2

    (@fallback2)

    6 months later, still happening!

    Do WP developers think images are not important? Text only?

    #
    I just had this issue (“Post Processing of the image failed…”) with a fresh WP install and tried updating PHP, memory, etc.

    Finally found it and its a conflict with gd and imagick extensions in php. Ultimately the fix was to disable imagick for image processing. If you have access to your PHP Extensions, make sure to enable GD and disable Imagick. Worked for me.

    This worked for me – thanks @sweetpweb!!

    @kempas Glad you got it!

    I’ve run into this on multiple new site installs since my OP. Depends on your version of PHP and the default extensions on your hosting, but this has worked every time for me. If you don’t have access, have your host do it for you.

    Ultimately the fix was to disable imagick for image processing. If you have access to your PHP Extensions, make sure to enable GD and disable Imagick.

    I had this today as well after automatically updating to WordPress 5.2.2. I tried a few of the suggestions listed in this thread, and I think that uninstalling imagick on the centos server fixed it. Annoying issue — hopefully fixed upstream soon.

    Truly we have tried just about everything.
    Nothing works except this:

    function use_gd_editor($array) {
    return array( 'WP_Image_Editor_GD', );
    }
    add_filter( 'wp_image_editors', 'use_gd_editor' );

    in wp-includes/functions.php

    …but this must be done over 200 times for every wordpress account on the server (?).

    We would opt to remove imagick, however the client does not want anything to be listed as “Missing” under the wordoress site health check (even if it’s optional). It’s suggested that the end client will think something is wrong with their website when they log in for their feedback.

    Hopefully the notation that the imagick php extension is ‘missing’ will be removed from the wordpress site health check… at least until the issue is resolved.

    Looking forward to a resolution pretty please!

    go to your active theme folder, open the functions.php file and add this pieace of code.

    add_filter( 'wp_image_editors', function() { return array( 'WP_Image_Editor_GD' ); } );

    Save the file, refresh and upload your image. it will work 100%

    Before adding anything to the function file, check if your image name has apostrophe (‘) in it. If so, remove that first and try to upload the image again.

    ahdkhalid

    (@ahdkhalid)

    Once do remove the cookies of the wordpress website before trying any of the solution and perhaps after each.

Viewing 15 replies - 31 through 45 (of 81 total)
  • You must be logged in to reply to this topic.