Support » Fixing WordPress » Error with image uploading

  • Resolved Mohamed Adel

    (@madel28)


    I have got the below error and It was not found before. and the image I upload it less than 2500px and still seeing this message:

    Post-processing of the image failed. If this is a photo or a large image, please scale it down to 2500 pixels and upload it again.

    I add this
    add_filter( ‘big_image_size_threshold’, ‘__return_false’ );
    to functions.php and installed Disable “BIG image” Threshold

    nothing fix the problem, What should I do?

Viewing 15 replies - 16 through 30 (of 81 total)
  • I found this error whilst inserting images from Gutenberg. Going directly to Media allowed image upload no prob’s, then back into the page edit to insert the uploaded images.

    Oh, and jeanbonfils & robinjunga, don’t use apostrophes in file names, EVER! Use a hyphen (-) or underscore (_). Any other special characters are just asking for trouble.

    • This reply was modified 1 year, 2 months ago by pluggy.

    I needed to update the “Squirrly” plugin… and it now works fine.

    @joshben Add from Server Worked the Magic! Thanks.

    hi guys,

    just a tip, you can’t find the plugin in “add new” so you will need to download it from https://wordpress.org/plugins/add-from-server/ and upload it because This plugin hasn’t been tested with the latest 3 major releases of WordPress. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

    besides, i suggest you delete the plugin after your mission is accomplished for security reasons.

    good luck.

    br,
    tom

    Going to your wp-includes folder and open your functions.php. From there, scroll down to the bottom of your file and add the following lines. From the time of this messege, it is currently working in an updated format the latest WordPress 5.4.2

    Add the following:

    function use_gd_editor($array) {
    	return array( 'WP_Image_Editor_GD', );
       }
       add_filter( 'wp_image_editors', 'use_gd_editor' );

    Upload, overwrite, goto your post where your trying to add the image, be patient since some of you out there want to upload a 4k image, which is understandable. It should only take about 20-30 seconds since it is a huge file.

    I only recommend this method if you have changed your Maximum Upload and Memory via php.ini or user.ini. You can read about those easy fixes if you have not done so.

    Installing a plugin to add files from the server is not an acceptable “resolution” to this problem.

    • This reply was modified 1 year, 1 month ago by USGoldNews.

    I have encountered this problem over the weekend and I assume it’s because the people who host my site have updated the cpanel. That’s the only change that’s been made.

    I tried increasing the memory limit in php ini editor on cpanel. That made no difference.

    I tried the BIG image plugin. That made no difference.

    I installed the ImageMagick Engine plugin. That made no difference.

    I really don’t want to have to do that long-winded workaround uploading via ftp – and by this point, it was the only option left, except for what Michael had suggested. So I tried Michael @fivvr’s suggestion – increase the maximum upload file (as well as memory, which I’d already done) and add the code to the functions.php file. AND IT WORKED! Thank you, Michael!!!!

    Just a quick question, though – do I need to create a child theme to ensure that code doesn’t get written over the next time there’s a theme update? (I think the answer is yes, but I’d rather check first before going through the faff of doing that… on all five of my websites…).

    And also… please, WordPress, for goodness’ sake, fix it!

    @libraryhelen thanks for the feedback and I am happy that this resolved your problem. My issue, on the other hand is still ongoing, since adding this code to my functions.php doe not fix my WP Engine hosted Divi site.

    Also, this might help someone else. Elegant Themes support team told me to add the following to my .htgaccess file, but I am running php v7.4 and cannot edit that file on WPE.

    <FilesMatch "(async-upload\.php|wp-cron\.php|xmlrpc\.php)$">
     Satisfy Any
     Order allow,deny
     Allow from all
     Deny from none
    </FilesMatch>

    First save the post without set featured image or uploading image and after that use ctrl+shift+r and once page is reloaded try to upload image again. In my case the problem was fixed. Have a nice day!!!

    This message is annoying because it strongly implies it’s thrown by wordpress itself, which it isn’t, it’s merely a javascript message which is triggered when literally anything goes wrong with the image upload – not necessarily processing at all. It is a generic error containing confusing guesswork.

    In our case it was caused by a 413 Request Entity Too Large – literally the server telling javascript exactly what the problem was.

    • This reply was modified 1 year, 1 month ago by clancyhood.

    @aequalsb

    This worked for me, thanks!


    Open WP Admin > Themes > Themes editor > Edit ‘Functions.php’ file

    Paste at the last the below lines:

    add_filter( ‘wp_image_editors’, function() { return array( ‘WP_Image_Editor_GD’ ); } );

    2millionways

    (@2millionways)

    Had the same error after deleting a browsing history in Chrome, even though I was forced to log in again … anyways not sure if related. closed the browser logged into the admin panel and error diapered.

    kevin_bt

    (@kevin_bt)

    @ahcreative answer worked for me! Definitely be sure to check you PHP’s upload limit though.

    claycrucible

    (@claycrucible)

    I am having this same problem, with both my own site and my spouse’s site – both using WordPress.org, but with different themes (but both on the same hosting account with GoDaddy). We have tried everything in this thread, still with no luck for either site. Occasionally an image upload goes through successfully, but it’s maybe one attempt out of ten, with no rhyme or reason (sometimes the same image fails repeatedly and then succeeds).

    We have tried:
    – Increasing the site’s memory limit in PHP, along with the max file size and max upload
    – Upgrading to the latest version of PHP (7.4), as well as then downgrading to 7.2
    – Using the Add From Server plugin
    – Making sure Imagick is installed in PHP (it already was)
    – Adding this code to the Theme Functions file (functions.php): add_filter( ‘wp_image_editors’, function() { return array( ‘WP_Image_Editor_GD’ ); } );
    – Adding this code to the Theme Functions file: add_filter( ‘big_image_size_threshold’, ‘__return_false’ );
    – Adding this code to the Theme Functions file: function use_gd_editor($array) {
    return array( ‘WP_Image_Editor_GD’, );
    }
    add_filter( ‘wp_image_editors’, ‘use_gd_editor’ );
    – Making sure there were no apostrophes in image file names
    – Checking to make sure I’m not using the Squirrly plugin (I’m not)

    I think that’s every solution offered in this thread; none has worked.

    Help!

    (And thank you!)

    EkahiDesign

    (@ekahidesign)

    Check your firewall settings. I changed mine and I can now upload photos.

Viewing 15 replies - 16 through 30 (of 81 total)
  • You must be logged in to reply to this topic.