WordPress.org

Support

Support » How-To and Troubleshooting » Error with having my blog to appear on index.php

Error with having my blog to appear on index.php

  • I installed my blog in http://mysite.com/wordpress/

    I read the instructions on

    http://wordpress.org/docs/installation/different-address/

    and follow them.. However, there are these errors on my index page now…

    Warning: main(./wp-blog-header.php): failed to open stream: No such file or directory in /home/icyerz/public_html/confession/wordpress/wp-content/themes/butterfly/index.php on line 1

    Warning: main(./wp-blog-header.php): failed to open stream: No such file or directory in /home/icyerz/public_html/confession/wordpress/wp-content/themes/butterfly/index.php on line 1

    Fatal error: main(): Failed opening required ‘./wp-blog-header.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/icyerz/public_html/confession/wordpress/wp-content/themes/butterfly/index.php on line 1

    Line one on my index page is

    <?php
    /* Short and sweet */
    define(‘WP_USE_THEMES’, true);require(‘./wordpress/wp-blog-header.php’);
    ?>

    Any idea how? Some one pls help?

Viewing 6 replies - 1 through 6 (of 6 total)
  • When you uploaded your files, did they all upload fully? Check for any files with 0 bytes in size. Also, did they all drop into their appropriate folders? What theme are you trying to use?

    Ya, I did… I’m using one of my own themes….

    I got it fix.. thanks for your help….

    The problem was that I got an extra <?php require(‘./wp-blog-header.php’);?> in my index.php of my themes…

    =)

    Thank you for posting the solution!

    Hello,

    I am now having the same problem. I checked my index.php theme file and I do not have that extra line in that I could remove. And the default index.php file seems OK. What could be the problem in my case?

    I am running my WP blog on a Windows server.

    Best regards,
    Peter

    I have my blog working But I found that the footer area is getting this error!

    What it could be please help.

    Warning: Invalid argument supplied for foreach() in /usr/wwwjfl/JFLMedia/html/peoplehood/wp-content/plugins/sem-theme/sem-theme.php on line 538

    http://www.peoplehood.org/

    Well, my admin found the problem.

    The path in the fourth line of the index.php file has ./ in front and by removing this page started working…

    I guess this is the difference between the unix and Windows server as on two unix servers the default install worked fine.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Error with having my blog to appear on index.php’ is closed to new replies.