Support » Plugin: Translate WP website - Weglot Translate » Error with gravity forms

  • Resolved ilardo75

    (@ilardo75)


    Hi,

    It seems that your latest version is creating some error with gravity forms:

    “PHP message: PHP Warning: array_key_exists() expects parameter 2 to be array, string given in /plugins/weglot/src/third/gravityforms/class-gf-filter-urls.php on line 45” while reading response header from upstream, , request: “POST

    It could be that this is error comes on form submission. I can not test this more on our live site.

    You should consider supporting staging environments and also it would be very useful for your users to roll back to previous versions. Or give the previous plugin versions available to download. None of these seems not to be possible at the moment if i understand correctly.

    Thanks

    • This topic was modified 3 months, 2 weeks ago by  ilardo75.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Remy B

    (@remyb92)

    Hello,

    Do you still have this error ? Can you send me a screenshot + URL where you got this ? You can send it to support@weglot.com

    Best

    Hi, I do not have this error anymore as i had to roll back to 3.0.2. I can not be using it the latest version on my live site.

    Plugin Author Remy B

    (@remyb92)

    Hello, ok did you send an email to support@weglot.com ?
    Best

    ilardo75

    (@ilardo75)

    Hi, yes i did. they are aware of this. I am waiting for the official update. As they gave me a new fixed version, but i can not be testing it on my live site. So i am not using this unofficial version. So also i do not have any idea is this version really working or not.

    I have talked about this before that you guys should really be thinking of supporting a staging site. As your customers are not able to test anything before making updates on their live site. And all problems that are found on the plugin can lead to very bad situations like in the two latest versions. Other one leading to translation changes and the other leading to fatal errors and plugin conflicts.

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.