Error with form (Referrer Missing or Mismatch) (8 posts)

  1. Oaiki
    Posted 7 years ago #


    I've configured the form, but something seems to be wrong and I can't figure out what. This is the error message I get when filling out my form:

    "Referrer Missing or Mismatch: It looks like you’re trying to post remotely or you have blocked referrers on your user agent or browser. Using your “Back” button, please go back and try again or use our regular email, herrnilsson@herrnilsson.se, to circumvent Referrer Mismatch."


  2. konvct
    Posted 7 years ago #

    You should check to see if your Your form page URL: in your contact form configuration is set properly.

    example: http://www.amaturegamers.com/?page_id=23

    NOT: http://www.amaturegamer.com


  3. GATEKeeper
    Posted 7 years ago #

    I'm getting the same error, and I definitely have the page URL set right. Tried both the "pretty" URL and with page ID instead. Any thoughts? Is it just because of my browser? Any way to fix it? I've looked at my logs and I think everyone is getting the error - haven't see a single email from it.

  4. repixel
    Posted 7 years ago #

    Same happens 2 me (with wp-gbcf), though I tried both referrers
    ( http://www.mysite.com/?page_id=23
    http://www.http://www.mysite.com ).
    could the host be the problem( e.g. httpp config or some
    other misconfiguration ) ?

    Or could the error result of something like this :

    wp-gbcf_form.php lines 1081 + 1113 ? ? ? ? ?

  5. GATEKeeper
    Posted 7 years ago #

    Best solution I found was just to use cformsII. Much more robust as well.

  6. krembo99
    Posted 7 years ago #

    Same problem here ...
    SOme browsers are not configured right,
    try this :
    To sort this problem out you do the following

    1 In the location bar type about:config then press the enter key

    2 Ignore frightening message and click on button I'll be careful, I promise!

    3 Scroll and find the line network.http.sendRefererHeader

    4 If the value is not 2 right click and change the value to 2 (if it is 2 then you have
    a different problem)

    5 Close Firefox and restart

    It did not resolved MY problem, but some people told me it resolved theirs...

  7. krembo99
    Posted 7 years ago #

    forgot :
    a second reason could be that you havent configured the reffering page option in config, set it to your contact form page.
    View the documentation for more info on this setting.

  8. flyingkites
    Posted 6 years ago #

    for me it was a missing / at the end of the URL


Topic Closed

This topic has been closed to new replies.

About this Topic