Support » Theme: Astra » error with elementor

  • I have read that in your new updates you have an optimization of html and css and I would like to know if that is what is causing us conflicts with elementor.

    It happens that when using the options: by default, theme or canvas elementor, the editor works correctly.

    The problem is when you want to use the “full width elementor” option, this is when the editor is shown small and when doing any editing it only shows in the middle of the screen.

    Here I leave the image so that the error is better understood: https://casaelmoro.com/wp-content/uploads/2021/04/error-elementor.jpg

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Thread Starter Alberto Olguin

    (@seobeto)

    update

    I have done some tests with a test page and indeed the problem comes from the Astra updates, the last version with which the “full width elementor” option works well is with 3.2.0

    I would like to know if this error has a solution so as not to have the theme outdated

    Can confirm same thing happens to me when you Template -> Elementor Full Width, it’s Astra’s theme fault.

    Hi @seobeto, @moultrex,

    This is what I have on my end, with the latest version of the Astra theme (v3.3.2) and latest version of the free Elementor plugin (v3.1.4).

    Let me know if I am missing something.

    Kind regards,
    Herman πŸ™‚

    Thread Starter Alberto Olguin

    (@seobeto)

    Hi @bsfherman

    Surely you are talking about an existing site to which only the update was made, if so, in effect you will not have any problem,

    in my case (https://casaelmoro.com/wp-content/uploads/2021/04/error-elementor.jpg) I am talking about new sites where everything is installed for the first time.

    I have other sites in which only the update was made and they did not suffer any problem, since the html and css optimization update only affected new sites that install Astra for the first time and not for sites that already had it installed, this for not affect your existing display.

    I have the same problem, Astra is not working well with Elementor anymore, this is terrible!
    I hope you can fix it soon, as I use Astra for so many websites, and I love it, but this is really bad…
    thanks!

    By the way, untill they fix it, an easy workaround is to do the following:
    set these things in the customizer:
    1. sidebar – no sidebar
    2. container – full widzh streched

    and then do not use “Elementor full width” but instead the “default template” and this should work for now…

    Thread Starter Alberto Olguin

    (@seobeto)

    Hi @ensof , so far no member of Astra has solved this error that I made known, I hope they solve it or that they are at least interested in doing it, in the meantime, I share that I have been able to continue working with Astra + Elementor returning to version 3.2.0

    I know it is not the best solution but we cannot wait for someone from Astra to answer.

    I hope it helps you, greetings.

    Hi,
    I actually reported it also in the Astra Webiste, and they are aware of it, and I got a really nice reply saying that they are working on it, and plan to publish an update on April 26!
    Good news, great theme with great support…
    Best

    Hi @seobeto, @ensof, @moultrex,

    Yes, this is an issue that our team is working to fix. The issue is related to the optimation we did as explained in this doc.

    The reason why this issue is not happening on the site updated to v3.3.x because in order to make the optimation works, there is a snippet, which is mentioned in the doc, that needs to be added to the site. And for the new fresh installation with Astra v3.3.x as the first install, this optimation already works.

    As a temporary workaround, please add the below snippet on your site

    add_filter( 'astra_apply_flex_based_css', '__return_false' );

    Once the update contains the fix, you can remove the snippet.

    Please let us know how it works.

    Kind regards,
    Herman πŸ™‚

    Also having the same issue. Very frustrating. Tried debugging for 2 hours before I found this thread. The snippet works so I want to thank you for providing it.

    I love Astra and I respect the ambition from the developers. I really, really, really wish you would test the theme before each update. It’s been 1 step forward 3 steps back for every update in 2021.

    Hello @chargeup

    We are sorry for the inconvenience caused!

    And thank you for the feedback, we take your feedback seriously, and has been shared with the concerned Astra’s Testing team.

    We have released an update with version 3.3.3 of the Astra theme that should resolve this issue.

    I hope that helps.

    thanks a lot!
    I just tested it and it looks great!!
    thanks for a fast and awesome service and a winderful theme…
    Best, Nils

    Hello @ensof

    Glad to hear that the issue has been fixed!

    We will be ensuring such an issue is not repeated. And we appreciate everyone’s patience and understanding.

    Have a great day and week ahead. πŸ™‚

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘error with elementor’ is closed to new replies.