WordPress.org

Support

Support » Installation » [Resolved] Error with automatic upgrade from 2.7 to 2.7.1

[Resolved] Error with automatic upgrade from 2.7 to 2.7.1

  • Hi guys
    I have two wordpress blogs, both using version 2.7. Today I was notified that version 2.7.1 was available so I tried to automatically upgrade using the WordPress Automatic Upgrade plugin (I don’t know if there’s anything else available. I use this one and it’s been working fine)
    Anyway while attempting to upgrade I received the following error message:

    Fatal error: Cannot redeclare class pclzip in /home/nefst3/public_html/sofia/wp-admin/includes/class-pclzip.php on line 171

    Above message appeared at both blogs and of course installation was not completed. I don’t want to upgrade manually, but I don’t know if there’s something wrong with my blogs, with the plugin or…whatever

    any help is much appreciated

Viewing 7 replies - 1 through 7 (of 7 total)
  • This one got me too! I have about 50 WordPress installs that I maintain, here is what you have to do, deactivate the automatic upgrade plugin! I know, it came as a shock to me too! Once you deactivate the plugin, there is a link on your dashboard as you said, it should work just fine. However, of these 50 plus sites I mentioned, I have 3 that I am getting an error on, that is why I am here now! I hope that helps.

    But…if I deactivate the plugin, how will I be able to automatically upgrade?

    Well I did what you said and YES upgrade completed quickly and with no problems. Should I reactivate the plugin now?

    I didn’t reactivate it, it seems to be an obsolete plugin now

    Automatic upgrade was added into the WP core as of version 2.7

    Thus the auto-update plugin is now obsolete and can be removed

    @nasose – don’t activate the WordPress Automatic Upgrade Plugin, DELETE IT. You don’t need it.

    I was having the same problem.
    I deactivated the plug in, and now the built in automatic upgrade WORKS LIKE A CHARM!

    Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Error with automatic upgrade from 2.7 to 2.7.1’ is closed to new replies.