Support » Plugin: Mollie Payments for WooCommerce » Error with 6.3.0

  • Resolved Ghostyvb13

    (@ghostyvb13)


    I just did a rollback to 6.2.2 because it seems that 6.3.0 is causing problems with all the latest other woocommerce and wordpress versions.

    The order emails where not being send and i got this error, hope below helps 🙂

    WordPress versie 5.7.2
    Huidig thema: Child Theme for Divi (versie 1.0)
    Huidige plugin: Mollie Payments for WooCommerce (versie 6.3.0)
    PHP versie 7.3.24

    Foutdetails
    ===========
    Een fout van het type E_ERROR werd veroorzaakt op regelnummer 28 van het bestand /var/www/vhosts/onzewebsite.nl/httpdocs/wp-content/plugins/mollie-payments-for-woocommerce/src/Mollie/WC/Helper/GatewaySurchargeHandler.php. Foutmelding: Uncaught ArgumentCountError: Too few arguments to function Mollie_WC_Helper_GatewaySurchargeHandler::setHiddenOrderId(), 3 passed in /var/www/vhosts/onzewebsite.nl/httpdocs/wp-includes/class-wp-hook.php on line 292 and exactly 4 expected in /var/www/vhosts/onzewebsite.nl/httpdocs/wp-content/plugins/mollie-payments-for-woocommerce/src/Mollie/WC/Helper/GatewaySurchargeHandler.php:28
    Stack trace:
    #0 /var/www/vhosts/onzewebsite.nl/httpdocs/wp-includes/class-wp-hook.php(292): Mollie_WC_Helper_GatewaySurchargeHandler->setHiddenOrderId(40936, Object(WC_Order_Item_Product), Object(Automattic\WooCommerce\Admin\Overrides\Order))
    #1 /var/www/vhosts/onzewebsite.nl/httpdocs/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters(”, Array)
    #2 /var/www/vhosts/onzewebsite.nl/httpdocs/wp-includes/plugin.php(484): WP_Hook->do_action(Array)
    #3 /var/www/vhosts/onzewebsite.nl/httpdocs/wp-content/plugins/woocommerce-pdf-invoices/includes/abstracts/abstract-invoice.php(445): do_action(‘woocommerce_ord…’, 40936, Ob`

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Error with 6.3.0’ is closed to new replies.